Last modified: 2005-09-12 19:56:09 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T3819, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 1819 - MediaWiki doesn't want to save when logged in
MediaWiki doesn't want to save when logged in
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
PC Linux
: Normal major with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2005-04-04 19:25 UTC by guaka
Modified: 2005-09-12 19:56 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description guaka 2005-04-04 19:25:59 UTC
Version 1.4.0.

MediaWiki doesn't want to save when logged in. I constantly says "Prévisualiser 
Note : Attention, ce texte n'est qu'une prévisualisation et n'a pas encore été
sauvegardé!". When not logged in it's working fine. It could be that it's only a
problem with the admin account.

And actually, just now I'm finding some more very peculiar things. When creating
a new user, I'm immediately logged out. It seems I can only log in as root.

No cookie problem...

Later more. No time right now.
Comment 1 Brion Vibber 2005-04-04 22:59:21 UTC
Fix your session storage, most likely you are on a server farm where PHP sessions are erroneously stored on the local /tmp 
drive instead of a shared location.

Comment 2 Andrew 2005-04-05 22:33:36 UTC
Ok, ive fixed the issue. however according to the user posts this is something that should have been set before. and 
perhapse even be listed in the common bug sections.

it should be noted that designofgod's is correct but your /tmp directory on SF has to have permissions of 777 or you 

designofgod at yahoo dot com
14-Feb-2005 07:12 
sometime you need to change session.save_path because server system distributed more then one machine and you can 
not reach php.ini file example Then you can do that with .htaccess file which is kind of 
configuration file for Apache under one directory. anyway I added

php_value session.save_path /home/groups/f/f4/f4l/tmp/

now my sessions work very well I hope :)

Comment 3 Andrew 2005-04-05 22:41:51 UTC
umm... sorry this wasnt my bug, but it did help fix my bug. and may help you with yours
Comment 4 Peter De Zutter 2005-05-25 20:00:35 UTC
Having the same problem, once logged in saving an edit always results in
previewing the edit.
This happend after an upgrade from 1.3.11 to 1.4.3. Also can conform it is not a
cookie problem.
and it runs on a single server. 
And for tommorow start logging everything at debug level, a bit overkill but it
may give some details.

MediaWiki: 1.4.3 
PHP: 4.3.11  
MySQL: 4.0.24
Comment 5 Peter De Zutter 2005-05-26 12:22:24 UTC
A little update, upgrading to 1.4.4 didn't also solved this problem.
Comment 6 Peter De Zutter 2005-06-02 23:12:51 UTC
The possible solution mention in comment 2 didn't solved it but after being
pointed in the right direction, thanks again Brion, I found that there was one
line in php.ini that was different compared to the php.ini-dist. Double checked
it on a local wiki on another machine which didn't have this problem.

This line: 
session.referer_check = 3600

I change the line to this: 
session.referer_check =

and after a restart of apache, logged in user could save their edits again.

Comment 7 Philippe Guglielmetti 2005-09-12 14:32:23 UTC
I just encounter this bug on a brand new wiki I just created, but I have no way of accessing the 
php.ini at my provider (
I guess there should be a way to correct this in the MediaWiki code rather than on php.ini.
Any idea ?
Comment 8 Brion Vibber 2005-09-12 19:56:09 UTC
Please don't reopen a bug because you have a support request on how to 
configure your machine.

Contact your provider and/or see the PHP documentation at

Note You need to log in before you can comment on or make changes to this bug.