Last modified: 2011-01-25 00:48:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18131 - {{SERVERNAME}} support needed
{{SERVERNAME}} support needed
Status: RESOLVED DUPLICATE of bug 18977
Product: MediaWiki extensions
Classification: Unclassified
CentralNotice (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Tomasz Finc
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 19:04 UTC by Danny B.
Modified: 2011-01-25 00:48 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2009-03-24 19:04:58 UTC
{{SERVERNAME}} support needed to distinguish the notices by exact project×lang combination.
Comment 1 Tomasz Finc 2009-03-24 21:48:41 UTC
This seem to be a problem in rebuildTemplates.php Messages retrieved from the MediaWiki space work just fine unless they have any locality information that needs to be recorded. Since were running on hume and our configs do not state explicitly (nor should they) where any project lives; an entry of "localhost" is recorded for the {{SERVERNAME}} . We set/unset wgSitename & wgLang already to circumvent this.

I can see two ways around this. Short circuit any {{SEVERNAME}} call to do a lookup against a config/dns pair (bad hacky idea) or as Danny_B pointed use an api call for expand templates.

Comment 2 Tomasz Finc 2010-06-07 22:05:44 UTC
Resolving in favor of Bug 18977 as it reports on the same general issue and has more eyes on the bug.

*** This bug has been marked as a duplicate of bug 18977 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links