Last modified: 2009-07-09 00:58:50 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17817 - Skin system needs some sanity
Skin system needs some sanity
Status: RESOLVED DUPLICATE of bug 6884
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 19:57 UTC by Chad H.
Modified: 2009-07-09 00:58 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Chad H. 2009-03-06 19:57:41 UTC
The skin system is batshit and needlessly confusing. Classes can subclass Skin, SkinTemplate or Monobook, making different forks of page structure. The skin system is not inviting for users, who instead use Monobook with a bunch of common CSS. There needs to be one unified process for skinning that is simple to understand and use.
Comment 1 Chad H. 2009-07-09 00:58:50 UTC

*** This bug has been marked as a duplicate of bug 6884 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links