Last modified: 2011-03-13 18:04:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 17218 - Provide a magic word for a user's online status
Provide a magic word for a user's online status
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
User preferences (Other open bugs)
unspecified
All All
: Lowest enhancement with 3 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://meta.wikimedia.org/w/index.php...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 04:06 UTC by Melancholie
Modified: 2011-03-13 18:04 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Melancholie 2009-01-29 04:06:11 UTC
There is a great way to misuse {{GENDER:}}:

{{GENDER:Username|online|busy|offline}}

Use the very same technique for a magic word {{STATUS:}}, please.
Like this, users can tell others whether they are online or not.

For the first this can be done manually (like with {{GENDER:}} already :-)
Afterwards you can improve it to be updated automatically (on log in/out, (in-)activity etc.), if you like.
Comment 1 X! 2009-01-29 04:11:56 UTC

*** This bug has been marked as a duplicate of bug 6109 ***
Comment 2 X! 2009-01-29 04:16:41 UTC

*** This bug has been marked as a duplicate of bug 13520 ***
Comment 3 Melancholie 2009-01-29 04:26:38 UTC
Bug 6109 is WONTFIXed, I don't like to see that. You can see that it already can work (manually):
http://meta.wikimedia.org/wiki/User:Melancholie?random=123

Just give it a proper name ({{STATUS}} or {{ONLINE}}), to not force people to misuse {{GENDER}}.

Bug 13520 is a MediaWiki extension that doesn't seem to be installed on Wikimedia, due to disabling/bypassing the cache. So, this is not a duplicate. Either make a magic word (exactly the same like {{GENDER}}) or see this as a request to enable Extension:OnlineStatus on Wikimedia wikis.
Comment 4 Gurch 2009-01-29 15:43:13 UTC
Changing gender to go offline, haha, I love it. Definitely the best MediaWiki feature abuse of the year so far. :)
Comment 5 Chad H. 2009-01-29 21:23:57 UTC
I'm not convinced this is actually do-able. {{GENDER:}} is parsed based on your user preference of gender, not the user you're currently looking at. The behavior is right, and this bug is actually INVALID, I believe.

FWIW: I'm very much against any of the per-user magic words (be it online status, username, user groups, etc) as they break the parser cache.
Comment 6 Casey Brown 2009-01-29 22:17:58 UTC
(In reply to comment #5)
> I'm not convinced this is actually do-able. {{GENDER:}} is parsed based on your
> user preference of gender, not the user you're currently looking at. The
> behavior is right, and this bug is actually INVALID, I believe.

1) I saw Melancholie do it on Meta-Wiki and change it. ;-)
2) Look here: http://translatewiki.net/wiki/Gender#Testing_and_more_examples  It seems to also show different users as different genders based on what *they* set.
Comment 7 Chad H. 2009-01-30 00:08:08 UTC
Looking at the code, it could potentially be one of two genders depending on the situation. For interface messages, it should always be in the gender you set in your preferences. Otherwise, it depends on the passed $user parameter. Not 100% where that user is coming from; is it the user who's page we're on? User who last purged the cache? User who added the tag?
Comment 8 Chad H. 2009-01-30 00:09:29 UTC
*facepalm* That would be the user passed in the parser function :p

So yes, disregard pretty much everything I've said. This "feature" does work as described.
Comment 9 Niklas Laxström 2009-02-21 09:21:30 UTC
Gender is cached, which means that pages are not updated even if user changes his gender preference. We cannot just provide it with a new name and pretend it would work as you want. You can't have dynamic content on normal pages - only in special pages.

 (In reply to comment #3)
> Just give it a proper name ({{STATUS}} or {{ONLINE}}), to not force people to
> misuse {{GENDER}}.

We are not forcing anybody.

> Either make a magic word (exactly the same like {{GENDER}}) or see this as a
> request to enable Extension:OnlineStatus on Wikimedia wikis.

One thing in one bug.


Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links