Last modified: 2010-05-15 16:03:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16964 - prop=links returns a title=""
prop=links returns a title=""
Status: RESOLVED DUPLICATE of bug 16965
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
1.13.x
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Roan Kattouw
http://en.wikipedia.org/w/api.php?act...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 00:56 UTC by Sam Reed (reedy)
Modified: 2010-05-15 16:03 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2009-01-11 00:56:54 UTC
http://en.wikipedia.org/w/index.php?oldid=262902484 is version of the page (http://en.wikipedia.org/wiki/Wikipedia:WikiProject_Outline_of_knowledge)


<pl ns="0" title=""/> is in the results

Cant find anything obvious on the page that would cause that, so not sure if its a page or a MW bug...

Either way, the API shouldnt return a result with no title... (IMHO at least)
Comment 1 Splarka 2009-01-11 02:09:40 UTC
Narrowed test case to <ref>[[A]]</ref>. This is a bug in MediaWiki or Cite, where _any_ link in a <ref> causes such an entry (always missing): <page ns="0" title="" missing="" />

Let roan close this bug though, he may want to have something handle null titles rather than mark INVALID.
Comment 2 Alex Z. 2009-01-11 03:43:23 UTC
marking as dupe of bug 16965, same problems, more details on that bug though

*** This bug has been marked as a duplicate of bug 16965 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links