Last modified: 2009-05-04 19:13:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16891 - Id conflicts between headers are possible in obscure circumstances
Id conflicts between headers are possible in obscure circumstances
Status: RESOLVED DUPLICATE of bug 10025
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.14.x
All All
: Normal minor with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://validator.w3.org/check?uri=htt...
: parser
Depends on:
Blocks: html
  Show dependency treegraph
 
Reported: 2009-01-05 16:26 UTC by Aryeh Gregor (not reading bugmail, please e-mail directly)
Modified: 2009-05-04 19:13 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-01-05 16:26:02 UTC
This input:

== a ==
== a ==
== a 2 ==

produces the anchors "a", "a_2", and "a_2" respectively.  A page containing these headings would therefore break XHTML validity (see URL).  Parser::formatHeadings() should check for this case, if anyone can be bothered.
Comment 1 David 2009-05-04 19:13:31 UTC

*** This bug has been marked as a duplicate of bug 10025 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links