Last modified: 2009-04-14 17:45:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16744 - CategoryTree: If called on non-existent category, exposes strip markers
CategoryTree: If called on non-existent category, exposes strip markers
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
CategoryTree (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Tim Starling
http://en.wikipedia.org/w/index.php?t...
: parser
Depends on: 17329 16129
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-21 17:21 UTC by P.Copp
Modified: 2009-04-14 17:45 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
proposed fix: wfMsgExt->wfMsgHtml (676 bytes, patch)
2008-12-21 17:27 UTC, P.Copp
Details
Change to wfMsgForContent so HTML markup can be used (673 bytes, patch)
2008-12-22 12:14 UTC, P.Copp
Details
Patch for i18n file, change ''$1'' to <i>$1</i> (8.83 KB, patch)
2008-12-22 12:15 UTC, P.Copp
Details

Description P.Copp 2008-12-21 17:21:07 UTC
When <categorytree>Foo</categorytree> is called on an non-existent category Foo, all strip markers before the tag are left stripped (see URL). Probably, there's a recursive call to the parser inside the extension which clears the parser state.
Comment 1 P.Copp 2008-12-21 17:27:10 UTC
Created attachment 5605 [details]
proposed fix: wfMsgExt->wfMsgHtml
Comment 2 Roan Kattouw 2008-12-21 19:32:55 UTC
Probably related to bug 16129, maybe even a duplicate.
Comment 3 P.Copp 2008-12-21 19:41:46 UTC
(In reply to comment #2)
> Probably related to bug 16129, maybe even a duplicate.
> 
Somehow related, yes. The cause is in both cases calling $wgParser->parse recursively, which clears the parser state and thus loses strip marker info.
Comment 4 P.Copp 2008-12-22 12:14:37 UTC
Created attachment 5610 [details]
Change to wfMsgForContent so HTML markup can be used

Sorry, I didn't notice that some of the messages used HTML markup.
Comment 5 P.Copp 2008-12-22 12:15:36 UTC
Created attachment 5611 [details]
Patch for i18n file, change ''$1'' to <i>$1</i>
Comment 6 Brion Vibber 2008-12-22 19:19:58 UTC
Sounds like same base issue as bug 16129.
Comment 7 Alexandre Emsenhuber [IAlex] 2009-04-14 17:45:22 UTC
fixed in r49471.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links