Last modified: 2011-01-25 00:48:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16574 - Allow administrators to temporarily disable the account creation limit for an IP address
Allow administrators to temporarily disable the account creation limit for an...
Status: RESOLVED DUPLICATE of bug 25000
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
unspecified
All All
: Normal enhancement with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 01:27 UTC by Gurch
Modified: 2011-01-25 00:48 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Gurch 2008-12-06 01:27:00 UTC
It would be nice if administrators could temporarily disable the account creation limit for particular IP addresses.

This would be particularly useful in situations such as that described in bug 16569. Ideally, we would be able to apply an anonymous-only block to the affected IP addresses, leave account creation enabled, and ask people to create accounts in order to contribute. However, the account creation limit was hit by each of the IP addresses within hours of the problem first arising. We thus have to fall back on the tedious process of asking people to e-mail a mailing list to ask for an account to be created for them. 

If an administrator could indicate "yes, this IP address is producing lots of account creation attempts, but please allow them all through for the next 24 hours", or something along those lines, it might alleviate the problem.

Another situation in which this might be useful is when a school wants each of its students to create an account for a class project of some sort. I recall several occasions where this has been done; in at least one case the limit was tripped and an administrator had to offer to manually create the remaining accounts for them; I don't recall if they were taken up on their offer. Being able to temporarily turn off the limit would be a cleaner solution.

Just a thought for next time.
Comment 1 Raimond Spekking 2010-09-14 09:02:44 UTC
[[MediaWiki:Ratelimit-excluded-ips]] added with r72959.
Comment 2 Gurch 2010-11-08 20:53:09 UTC
Or not.
Comment 3 Platonides 2010-11-08 21:05:54 UTC
Note that you can request a temporary exemption (just open a bug).

Although I agree that a better interface would be nice.

Duping to bug 25000 since it was more discussed there.

*** This bug has been marked as a duplicate of bug 25000 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links