Last modified: 2009-08-25 22:45:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16273 - Add a parser function or magic word for complex formatting of numbers
Add a parser function or magic word for complex formatting of numbers
Status: RESOLVED DUPLICATE of bug 13025
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 18:15 UTC by Huji
Modified: 2009-08-25 22:45 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Huji 2008-11-07 18:15:04 UTC
As an enhancement, I suggest allowing more formatting options with formatnum. It should:

* Allow localization of a number given the destination locale: {{formatnum:123|fa}} should output ۱۲۳ regardless of the content language of the wiki on which it is run.
* Allow deciding about how to handle decimals: bug 10454 is relevant here.
* Allow deciding about how to handle thousands separated: one should have a way to output a number without thousands separators. This is for example useful when you want to add/substract two years (four digit latin numbers) using ParserFcuntions, and show the results in a localized way.

I thought these are so bound together that they deserve to be requested in one bug rather than several separate bugs.
Comment 1 Niklas Laxström 2008-12-16 07:45:50 UTC
I'd perhaps keep formatnum as is for interface messages and introduce something else for content.
Comment 2 Niklas Laxström 2009-04-07 08:55:10 UTC
Re-purposing this bug as per my comments in bug 10454.
Comment 3 Niklas Laxström 2009-04-07 13:35:43 UTC
*** Bug 17659 has been marked as a duplicate of this bug. ***
Comment 4 Chad H. 2009-08-25 22:45:15 UTC

*** This bug has been marked as a duplicate of bug 13025 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links