Last modified: 2008-11-11 11:52:47 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16108 - Some <inputbox> parameters broken
Some <inputbox> parameters broken
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
InputBox (Other open bugs)
unspecified
PC Linux
: Normal normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
http://fr.wikinews.org/wiki/Page:Foot...
:
: 16307 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-25 14:19 UTC by Bertrand GRONDIN
Modified: 2008-11-11 11:52 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
screenshot of input box (3.79 KB, image/png)
2008-10-25 14:21 UTC, Bertrand GRONDIN
Details
Patch to remove tabs from inputbox output (1.14 KB, patch)
2008-10-27 17:48 UTC, P.Copp
Details

Description Bertrand GRONDIN 2008-10-25 14:19:59 UTC
The extension has some parameters broken in Wikimedia Fundation project like Wikinews

For the following source wiki code : 
<center>
<inputbox>
type=create
preload=Page:Football/Première page
editintro=Page:Football/Intro nouvel article
width=45
defaulttext=Championnat de France 2008/2009 de Ligue x :
bgcolor=#f8f8ff
</inputbox>
</center>

So, I see now two bugs in french wikinews : 

* 'default' parameter is broken and doesn't display text entered
* The 'createarticle' message is broken, too. The submit button display now : Submit Query instead 'Create Article' from createarticle message in InputBox.i18n.php file.

I think it's a problem about parametring Wikimedia Project : the extension works perfectly in my own wiki.
Comment 1 Bertrand GRONDIN 2008-10-25 14:21:11 UTC
Created attachment 5466 [details]
screenshot of input box
Comment 2 Platonides 2008-10-25 14:24:54 UTC
The 'createarticle' message is not broken. It's not used. 'Submit Query' is the default text on your browser for buttons without caption.
The value attribute is missing: <input name="create" class="createboxButton" type="submit">
Comment 3 Bertrand GRONDIN 2008-10-25 14:53:07 UTC
Sorry, With the same code, Inputbox runs perfectly with the same browser in my own wiki. So, the code : input name="create" class="createboxButton" type="submit"> does'nt run on Wikimedia project. 

It's really a Wikimedia bug.
Comment 4 Bertrand GRONDIN 2008-10-25 14:57:29 UTC
Yesterday, the code run perfectly in french wikinews, it seems it's due to a mediawiki update on Wikimedia project
Comment 5 P.Copp 2008-10-25 20:48:43 UTC
I think this bug is caused by r42257 which replaces tabs with &#9; entities. For the inputboxes, the following happens:

<input class="createboxInput" name="title" type="hidden"
\tvalue="Test" size="50" />

is converted to

<input class="createboxInput" name="title" type="hidden"
&#9;value="Test" size="50" />

which causes Tidy to remove the value attribute from the tag.
Comment 6 P.Copp 2008-10-25 22:12:17 UTC
P.S. This also affects en.wikipedia: [[Wikipedia:Articles for creation/Wizard-Ready for submission]] is currently redirecting to the main page, when anons try to submit a new article.
This can be fixed by either removing the tabs from the output at /extensions/inputbox/inputbox.php or by reverting r42257
Comment 7 P.Copp 2008-10-27 17:48:41 UTC
Created attachment 5478 [details]
Patch to remove tabs from inputbox output

adding patch to remove tabs from inputbox form (see comments above)
Comment 8 Anatoliy Goncharov 2008-10-27 20:52:18 UTC
I see the text on the button «Надіслати» (in Ukrainian) and some my friends from Ukrainian Wikipedia see the text «Отправить запрос» (in Russian)
Comment 9 Platonides 2008-10-27 21:26:22 UTC
That's because the value parameter isn'tbeing provided, Anatoliy. The difference lies on your different browsers/browser configurations. Will be fixed with this bug.
Comment 10 Trevor Parscal 2008-10-27 21:44:31 UTC
After refactoring the code, this problem has been solved. It ended up that using tidy html combined with using a tag with attributes that span more than one line would result in truncating the attributes which were not on the first line.
Comment 11 Martin 2008-10-28 12:45:27 UTC
This problem is still apparent on en.wikipedia. For example, see http://en.wikipedia.org/wiki/Help:Inputbox
Comment 12 Trevor Parscal 2008-10-28 16:55:54 UTC
en.wikipedia.org is not using the latest version. The new version does not use tables for instance.
Comment 13 Martin 2008-10-28 16:57:59 UTC
Well it's not even working at http://www.mediawiki.org/wiki/Extension:Inputbox
Comment 14 Trevor Parscal 2008-10-28 17:00:09 UTC
www.mediawiki.org is also not running the latest version. Look at the code it's outputting. The latest version uses divs instead of tables and the style parameter to set the background color instead of bgcolor.
Comment 15 Mike.lifeguard 2008-10-28 17:01:39 UTC
(In reply to comment #13)
> Well it's not even working at http://www.mediawiki.org/wiki/Extension:Inputbox
> 

I think what he's trying to say is that the bug has been fixed in SVN, but it has not gone live yet. If that's the case, this should be re-marked as FIXED. Perhaps noting the revision number here so users can compare to Special:Version would be prudent.
Comment 16 Mike.lifeguard 2008-10-28 17:07:12 UTC
Though it's not noted in the commit message, r42662 is the fix.
Comment 17 X! 2008-11-11 11:52:47 UTC
*** Bug 16307 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links