Last modified: 2008-10-25 13:04:53 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 16101 - API request returns invalid XML
API request returns invalid XML
Status: RESOLVED DUPLICATE of bug 15261
Product: MediaWiki
Classification: Unclassified
API (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks: 16106
  Show dependency treegraph
 
Reported: 2008-10-25 00:10 UTC by carnildo
Modified: 2008-10-25 13:04 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
The malformed XML document (471 bytes, text/plain)
2008-10-25 00:10 UTC, carnildo
Details

Description carnildo 2008-10-25 00:10:09 UTC
Created attachment 5464 [details]
The malformed XML document

Visit the URL http://en.wikipedia.org/w/api.php?action=query&format=xml&iiprop=comment&prop=imageinfo&titles=Image:Shakerredraider.jpg

Expected result: A well-formed XML document

Actual result: The attached document.  The character at byte offset 199 is not permitted in XML.
Comment 1 X! 2008-10-25 00:59:42 UTC
The error was because the user upploaded with a horrible summary. 
Comment 2 Bryan Tong Minh 2008-10-25 09:08:21 UTC
All UTF should be sanitized perhaps before outputting it.
Comment 3 Roan Kattouw 2008-10-25 13:04:53 UTC

*** This bug has been marked as a duplicate of bug 15261 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links