Last modified: 2012-10-29 16:39:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15814 - Special:RevisionDelete should have clearer logs for individual revisions
Special:RevisionDelete should have clearer logs for individual revisions
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Aaron Schulz
: schema-change
: 18049 (view as bug list)
Depends on:
Blocks: SWMT 15644
  Show dependency treegraph
 
Reported: 2008-10-03 08:33 UTC by MZMcBride
Modified: 2012-10-29 16:39 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MZMcBride 2008-10-03 08:33:35 UTC
After deleting several revisions of a page, if you click "show/hide" for a specific revision, it can be incredibly difficult to determine which log entry applies to the selected revision.

Preferably the interface would make it clearer why the specific revision was hidden. Perhaps by aggregating the log entries specific to that revision and showing them in a separate area rather than merged with all the deletion log entries for the page.

Example: http://test.wikipedia.org/w/index.php?title=Special:RevisionDelete&target=Revision_deletion&oldid=63902

The log shows four entries and it makes it difficult to know why that specific revision was hidden.
Comment 1 Aaron Schulz 2008-10-20 22:57:08 UTC
Needs a schema change, will commit later
Comment 2 MZMcBride 2008-12-21 21:28:14 UTC
Bumping bug (not supposed to do that, yeah, yeah), but it's two months yesterday since the previous comment was made.
Comment 4 Aaron Schulz 2009-03-22 06:03:34 UTC
*** Bug 18049 has been marked as a duplicate of this bug. ***
Comment 5 FT2 2009-03-22 06:30:32 UTC
Copied from Bug 18049 (dup):

RevisionDelete logging should be made clearer before being opened to admins

EXAMPLE 1:
----------

A sample entry in the suppression log, for a hidden item, looks like this:

TIMESTAMP OVERSIGHTER (talk | contribs | block) changed revision visibility of
ARTICLENAME ‎(hid content (applied restrictions to administrators) for 1
revision: remove personal attack) (Change visibility) 

TIMESTAMP OVERSIGHTER (talk | contribs | block) changed revision visibility of
ARTICLENAME ‎(hid content, edit summary, username (applied restrictions to
administrators) for 1 revision: Didn't happen) (Change visibility) 


But if the item hidden is a log entry, it looks like this, which is extremely
obscure for other patrollers and reviewers:

TIMESTAMP OVERSIGHTER (talk | contribs | block) changed event visibility of
(Move log) ‎ (hid content, edit summary (applied restrictions to
administrators) for 1 event: removal of personal information) (Change
visibility)

TIMESTAMP OVERSIGHTER (talk | contribs | block) changed event visibility of
(Deletion log) ‎ (hid content, edit summary, username (applied restrictions
to administrators) for 1 event: Unecessary log entry) (Change visibility)



EXAMPLE 2:
----------

Likewise in the delete log, changes made through RevisionDeleted are not
clearly detailed (compared to entries from ordinary deletion), which obscures
its use and hinders review:

01:51, February 18, 2009 FT2 (talk | contribs | block) deleted "Hindustan
Hamara Citizens' Initiative" ‎ (CSD A7: Article on a person, group, or web
content, doesn't indicate the importance or significance of its subject)
(restore) 
23:25, February 17, 2009 FT2 (talk | contribs | block) restored "User:FT2/test"
‎ (3 revisions restored) 

But: 

19:19, February 10, 2009 FT2 (talk | contribs | block) changed event visibility
of (Move log) ‎ (hid edit summary for 1 event: also remove edit comment)
(Change visibility)


The log entries when RevisionDeleted is used, must be made a lot clearer, if
RevDeleted is going to be successfully rolled out. Suggested format something
like this:


TIMESTAMP USERNAME (talk | contribs | block) changed visibility of a log entry
(move of SOURCEPAGENAME to DESTINATIONPAGENAME - username hidden, edit summary
hidden for <N> revisions) "Defamatory comments in log" ‎(Change)
Comment 6 Aaron Schulz 2009-03-25 18:25:50 UTC
Log filtered to the relevant rev(s) in r48839

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links