Last modified: 2010-05-15 15:34:02 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 1540 - Files containing the letter "ş" in the filename cannot be uploaded.
Files containing the letter "ş" in the filename cannot be uploaded.
Product: MediaWiki
Classification: Unclassified
Uploading (Other open bugs)
PC Windows XP
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2005-02-15 11:03 UTC by Erdal Ronahi
Modified: 2010-05-15 15:34 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Erdal Ronahi 2005-02-15 11:03:11 UTC
It is not possible to upload a jpg file if the filename contains the letter "ş"
(common in Turkish and Kurdish). Problems can be circumented easily by renaming
the file, but it's nevertheless a bug.

The letter "ş" or "Ş" respectively has caused problems in page titles before,
but they were all solved. This letter freqently causes encoding problems.
Comment 1 Brion Vibber 2005-02-15 18:34:40 UTC
Can you please give some more information?
* Which wiki are you experiencing the problem on? For instance, does this problem happen on the Turkish 
Wikipedia, or only on the English Wikipedia? Or are you on some other site altogether? If so how is it configured? 
For Unicode or Latin-1? A Latin-1 wiki such as the English Wikipedia would most likely reject such a filename due 
to lack of support for this character.
* Which web browsers have you tested? Does this problem occur only with Internet Explorer, for instance, or does 
it happen with other browsers as well? What versions?
Comment 2 Erdal Ronahi 2005-02-15 21:37:15 UTC
Maybe false alarm. The error only happens with Firefox 1.0, not with IE6 or
Opera 7.54, so it may be a Firefox-related problem.

I could reproduce the error on ku: and de:, both utf-8 wikis.  I tried three
file names to single out the problem. The file names were "nexşeya.jpg",
"aş_tr.jpg" and "aş.jpg". I have uploaded lots of pictures on ku: and never
experienced a problem before.
Comment 3 Antoine "hashar" Musso (WMF) 2006-05-01 12:05:30 UTC
Erdal, can you retry uploading such file ? That should be fine now
as we moved everything to utf-8 with 1.5.

Feel free to reopen the bug if it still happen.
Comment 4 Erdal Ronahi 2006-05-03 12:51:12 UTC
Well, on ku (Kurdish) it still does not work. A testfile named ŞşŞ.png is being
renamed to SsS.png and declared empty. The error message is:

The file you uploaded seems to be empty. This might be due to a typo in the file
name. Please check whether you really want to upload this file.

To change the filename in the upload form manually doesn't help.
Comment 5 Erdal Ronahi 2006-05-03 12:54:02 UTC
It also does not work on The bug is still there. It appears
before the actual uploading, just when the file is selected. The ş is then
changed into s, and of course the file cannot be found.
Comment 6 Brion Vibber 2006-05-03 22:36:31 UTC
This is a Firefox/Mozilla bug:

It's been fixed in development, and seems to work ok with current 
nightly builds of Firefox. I'm afraid there's not much we can do on our 
end about the existing buggy versions, though; you'll have to either use 
an experimental build or another browser like Opera or IE to upload such 

(You might want to put a notice into the upload directions for your 
language, though.)

Since the root cause is fixed upstream I'm going to mark this FIXED.

Note You need to log in before you can comment on or make changes to this bug.