Last modified: 2008-10-01 16:44:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15070 - Allow <ref>s from multiple pages to be collected into one <references/> on another page
Allow <ref>s from multiple pages to be collected into one <references/> on an...
Status: RESOLVED DUPLICATE of bug 10092
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on: 15071
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 17:45 UTC by Mike.lifeguard
Modified: 2008-10-01 16:44 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Mike.lifeguard 2008-08-07 17:45:21 UTC
Textbooks generally do not have footnotes, and Wikibooks discourages their use for that reason. We still want to have the ability to provide precise sourcing in textbooks however. We would like to have the ability to use <ref>...</ref> throughout a book, and have a single <references/> which would then list all the references for the whole book. Since there is nothing in the database schema to discern what pages form a book, this will likely necessitate some hack like

<references pages=
Book/Intro,
Book/Table of Contents
Book/Chapter 1
...
>

or something similar where all the pages of the book are specified manually.
Comment 1 Siebrand Mazeland 2008-08-10 23:14:11 UTC
Cannot go beyond the page at the moment. Completely depends on the 'page collection' concept defined in bug 15071.
Comment 2 Andrew Whitworth 2008-10-01 16:44:23 UTC
(In reply to comment #0)
> Textbooks generally do not have footnotes, and Wikibooks discourages their use
> for that reason. We still want to have the ability to provide precise sourcing
> in textbooks however. We would like to have the ability to use <ref>...</ref>
> throughout a book, and have a single <references/> which would then list all
> the references for the whole book. Since there is nothing in the database
> schema to discern what pages form a book, this will likely necessitate some
> hack like
> 
> <references pages=
> Book/Intro,
> Book/Table of Contents
> Book/Chapter 1
> ...
> >
> 
> or something similar where all the pages of the book are specified manually.
> 

This bug is a duplicate of #10092 that I've been watching for a while.

*** This bug has been marked as a duplicate of bug 10092 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links