Last modified: 2009-08-17 22:35:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15039 - Centered thumbnails in tables pushes table border right
Centered thumbnails in tables pushes table border right
Status: RESOLVED DUPLICATE of bug 4439
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
http://da.wikipedia.org/wiki/Bruger:W...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 22:25 UTC by Anders Wegge Jakobsen
Modified: 2009-08-17 22:35 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Anders Wegge Jakobsen 2008-08-04 22:25:50 UTC
The page mentioned above contains a minimal example of a weird rendering with IE7. It will likely show the same in other IE versions. The problem is the <div class="center"> that wraps the thumbnail when |center| is given in [[Image:Eksempel.jpg|100px|thumb|center|center]].

I seem to recall that there are some issues with IE and block-level elements having a width of 100% the surrounding block. In this case it looks like the 6px of padding from <div class="thumbinner" is applied to the table cell *after* the width has been calculated, and therefore the border is shifted into the cell to the right. Changing width: 100% to a smaller value or removing it entirely, in the CSS, fix this case, but I'm not sure if such a change will break something else. However, the simple skin has no width at all for div.center.
Comment 1 Chad H. 2009-08-17 22:35:14 UTC

*** This bug has been marked as a duplicate of bug 4439 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links