Last modified: 2008-08-11 04:29:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 15035 - Link trail uses PHP 5.1 only feature
Link trail uses PHP 5.1 only feature
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.14.x
All All
: Normal enhancement (vote)
: ---
Assigned To: Tim Starling
http://nl.php.net/manual/en/regexp.re...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 14:16 UTC by Jelte (WebBoy)
Modified: 2008-08-11 04:29 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jelte (WebBoy) 2008-08-04 14:16:18 UTC
The current $linkTrail in MessagesEn.php is:

$linkTrail = '/^(\p{L&}+)(.*)$/usD';

According to http://nl.php.net/manual/en/regexp.reference.php#regexp.reference.unicode \p is only available since PHP 5.1.0, but according to http://www.mediawiki.org/wiki/Installation MediaWiki requires only PHP 5.0.
Comment 1 Roan Kattouw 2008-08-04 14:17:08 UTC
I suggest we just up the requirements and require 5.1 then. Some 5.0 versions are broken anyway.
Comment 2 Brion Vibber 2008-08-04 20:48:50 UTC
Release issue, assigned to Tim.
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2008-08-04 20:51:42 UTC
As I've mentioned to Tim, this is also not available in the default RHEL PHP 5.1.  My PHP error log is full of this:

[04-Aug-2008 15:47:47] PHP Warning:  preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Compilation failed: support for \P, \p, and \X has not been compiled at offset 3 in /var/www/w/includes/Linker.php on line 1364

And I can't find a package to install that will add support for it, either.
Comment 4 Tim Starling 2008-08-08 03:55:47 UTC
Fixed in r38751, will be backported to 1.13.0rc2.
Comment 5 Brion Vibber 2008-08-11 01:03:02 UTC
The fix was a revert to the ancient lowercase-ASCII-a-z-only linktrail, and caused regressions for all the languages whose custom linktrails were removed due to the default one finally being reasonably inclusive.

(Polish at least recently reinstated a specific one.)

I'd recommend at least extending the default to cover all Latin letters. (IMHO inconsistency of the linktrail among languages is another of those evil things that makes parsing harder...)
Comment 6 Tim Starling 2008-08-11 04:29:30 UTC
Checked all references to linkTrail in the log for possible removals, backported r39116 (pl linkTrail restore) to REL1_13. A linkTrail covering all latin letters would be good for 1.14, but I don't think it's worthwhile making such a change in 1.13. 

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links