Last modified: 2009-08-25 22:51:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 14792 - Using ref inside formatnums causes parser error
Using ref inside formatnums causes parser error
Status: RESOLVED DUPLICATE of bug 2257
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-11 22:15 UTC by Luna Santin
Modified: 2009-08-25 22:51 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Luna Santin 2008-07-11 22:15:28 UTC
Any use of a <ref> tag inside a {{formatnum:}} seems to result in a UNIQ marker getting dumped into the final output.

Specifically, I am looking at an enwiki article[1]. An infobox on the page[2] formats one variable using formatnum, and in this case the variable includes a ref tag (which in turn includes a citation template[3]).

As best as I can tell, the only steps necessary to reproduce this are to use any formatnum with any ref. I specifically tested this with {{formatnum:<ref>Hi</ref>}} if that helps any.

[1] http://en.wikipedia.org/w/index.php?title=Bettendorf%2C_Iowa&oldid=225101322
[2] http://en.wikipedia.org/wiki/Template:Infobox_Settlement
[3] http://en.wikipedia.org/wiki/Template:Cite_web
Comment 1 Niklas Laxström 2008-07-12 07:49:29 UTC
You cannot user <tags> inside formatnum, but the way it currently fails is probably not the best either.
Comment 2 Niklas Laxström 2008-07-12 07:55:24 UTC
It may be possible to use {{#tag:}} to force correct parsing order.
Comment 3 Chad H. 2009-08-25 22:51:28 UTC

*** This bug has been marked as a duplicate of bug 2257 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links