Last modified: 2011-01-27 20:28:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11779 - Re-add default $wgLogo and other useful path customisation lines to LocalSettings.php
Re-add default $wgLogo and other useful path customisation lines to LocalSett...
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
: 11553 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2007-10-27 13:12 UTC by Steve
Modified: 2011-01-27 20:28 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Steve 2007-10-27 13:12:58 UTC
I just downloaded 1.11. DefaultSettings.php has this line:

$wgLogo = false; /// defaults to "{$wgStylePath}/common/images/wiki.png"

Nothing I've tried to enter in LocalSettings.php affects the logo in anyway other than to make it disappear. The only way I've been able to change the logo is to rename my log file to wiki.png.

Even using $wgLogo = "$wgScriptPath/skins/common/images/mywikilogo.png";
has not worked.

Any idea?
Comment 1 Robert Leverington 2007-10-27 13:15:21 UTC
It does work. Please do not use bugzilla as a support method, instead use the mailing list or IRC. Thanks.
Comment 2 Steve 2007-10-27 13:37:11 UTC
I am not attempting to use bugzilla as a support method! The recommended way of customizing the logo does not work on my installation of 1.11 and I have just confirmed this again with the following tests in LocalSettings.php. See also Others have experienced the same problem. See

# 1. Copy wiki.png to mywikilogo.png
# 2. Verify path to mywikilogo.png as being
#    C:\wamp\www\mywikipedia\skins\common\images\mywikilogo.png
# 3. Uncomment each test line until finding one that works

# 4. Test recommended code per documentation: Does not work
#$wgLogo = "$wgStylePath/common/images/mywikilogo.png";

# 5. Test recommended code per Does not work
#$wgLogo = "$wgScriptPath/skins/common/images/logo.png";

# 6. Test removing $wgLogo line completely: Does work if new logo is renamed to wiki.png
Comment 3 Robert Leverington 2007-10-27 13:46:51 UTC
As you can see on [1] I can set my $wgLogo fine (MediaWiki 1.11.0). Maybe if you used the proper support mechanisms we could help you. This is clearly not a bug with MediaWiki.
Comment 4 Robert Leverington 2007-10-27 13:47:16 UTC
My applogies for not including the link:

Comment 5 Steve 2007-10-27 14:15:40 UTC
Apparently it is not a but in the code, but it *is* a problem with the documentation.

I was recommended a fix, which works, as follows:

(1) Do not use $wgStylePath (apparrently it is undefined and DefaultSettings.php's statement that $wgLogo defaults to {$wgStylePath}/common/images/wiki.png is now inaccurate or misleading)

(2) Use $wgScriptPath

Since $wgLogo no longer appears in LocalSettings.php, it isn't clear where the line should be placed. It must be placed at a point below the line which defines $wgScriptPath.
Comment 6 Rob Church 2007-10-28 20:34:34 UTC
It strikes me as absurd that certain lines containing useful lines, e.g. the $wgLogo line, despite having the same effect as the default settings, have been removed from the generated LocalSettings.php file.

It's not clear why this was done, but I strongly suggest reverting it; it's not at all helpful to new users poking about for things to change in LocalSettings.php.
Comment 7 Steve 2007-10-28 20:43:22 UTC
See also
Comment 8 Niklas Laxström 2009-02-28 19:07:39 UTC
*** Bug 11553 has been marked as a duplicate of this bug. ***
Comment 9 Mark A. Hershberger 2011-01-27 20:28:42 UTC
Since this is in the 1.17 LocalSettings.php file, I don't think this bug should remain open.

Note You need to log in before you can comment on or make changes to this bug.