Last modified: 2010-05-15 15:56:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T13153, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 11153 - Browser asks me to select application for opening file
Browser asks me to select application for opening file
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
PC Windows 2000
: Normal blocker (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2007-09-02 10:38 UTC by James R MacLean
Modified: 2010-05-15 15:56 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---

image of prompt (30.89 KB, image/jpeg)
2007-09-02 10:38 UTC, James R MacLean

Description James R MacLean 2007-09-02 10:38:46 UTC
Created attachment 4068 [details]
image of prompt

I am attempting to install MediaWiki 1.6.10 on my host at Hurricane Electric. They have PHP 4.4 and MySql 4.0.25; that's why I'm using release 1.6.10.  When I complete the installation, and direct the browser to the wiki directory, I receive a prompt (see attached) asking me to choose what application I want to open the file with.
Comment 1 James R MacLean 2007-09-02 10:40:06 UTC
I should mention this happens in Netscape Navigator, Mozilla Firefox, and MS-IE.
Comment 2 Andrew Garrett 2007-09-02 10:40:14 UTC
PHP isn't installed properly on your end. Not our problem.
Comment 3 Rob Church 2007-09-02 16:30:03 UTC
(Specifically, it appears that Apache or whatever HTTP server is running is misconfigured, and is serving up .php files, rather than passing them to PHP first...)
Comment 4 James R MacLean 2007-09-02 21:07:50 UTC
The problem is now solved. What happened was that, initially, I had installed release MW 1.10.1, but my web host only supported PHP4.4, not PHP5 (which is a requirement of release 1.10.1). So I used the SSH client to delete the /wiki directory and replaced it with a new one containing release 1.6.10. This time, I got the same error. That's when I posted here the first time.

A tech guy at my webhost kindly noticed that it worked for him, so perhaps it was necessary for me to flush my DNS resolver cache. It worked, and I'm in business. Thanks to everyone for listening and diagnosing

Note You need to log in before you can comment on or make changes to this bug.