Last modified: 2010-05-15 14:36:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 110 - Uncategorizedpages gives a fatal error
Uncategorizedpages gives a fatal error
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Timwi
Depends on:
  Show dependency treegraph
Reported: 2004-08-16 06:02 UTC by Timwi
Modified: 2010-05-15 14:36 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Timwi 2004-08-16 06:02:45 UTC
Originally submitted by Marko Faas (d_argus)  2004-08-11 00:07

When I enter the page

I get the following error message:

Fatal error: Call to undefined function: tablenames()
on line 21

------------------------- Additional comments ------------------------
Date: 2004-08-11 00:09
Sender: nobody
Logged In: NO 

Do you get the same error on Special:Lonelypages too?
Date: 2004-08-11 00:32
Sender: SF user timwi

Anyway, here are my theories.

(1) If you get the same error on Special:Lonelypages, then
it is likely that you have an old version of Database.php.

(2) If you don't, then I'm at a loss, because
Special:Lonelypages uses the exact same function.
Date: 2004-08-11 00:47
Sender: SF user vibber

Lonelypages is fine on REL1_3. Uncategorizedpages is also
using DB_SLAVE which is undefined. Was it correctly
backported from head?
Date: 2004-08-11 02:17
Sender: SF user timwi

After a bit of committing back and forth, brion and I have
fixed this problem, both in REL1_3 and in HEAD :-)
Comment 1 Timwi 2004-08-17 17:10:30 UTC
brion: has the fix for this been put live yet?
Comment 2 Brion Vibber 2004-08-17 20:48:41 UTC
Yes, it's been live for a while. I thought you closed this report on SourceForge before?

Note You need to log in before you can comment on or make changes to this bug.