Last modified: 2007-08-21 16:16:32 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T12916, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 10916 - Editing last diff causes re-edit of that diff instead of creating a new edit
Editing last diff causes re-edit of that diff instead of creating a new edit
Status: RESOLVED DUPLICATE of bug 9112
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2007-08-14 12:56 UTC by Eep²
Modified: 2007-08-21 16:16 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Eep² 2007-08-14 12:56:14 UTC
The last diff(erence) "edit" link does not have an "&oldid" so, one would think, editing it would be like editing the page normally. Apparently not so, as I've been finding out lately. If it's edited, the result is the combination of the previous diff and the new edit, making it seem like the latest edit did both edits. I don't know if it's a bug with MW 1.11a or what, but I didn't used to have this problem in Wikipedia before a few weeks ago (when I was banned--ahem). Anyway, I keep noticing it on and Meta and am getting sick of it so here's the bug report.
Comment 1 Rob Church 2007-08-14 13:14:13 UTC
What "last difference" link, where? Please give precise steps to reproduce, explain what the actual behaviour is, what the expected behaviour is, and state how what is happening is wrong.
Comment 2 Eep² 2007-08-14 13:31:33 UTC
1. Go to the history of any page.
2. Click the "last" (difference) link (to compare the last and previous edits).
3. Hover the mouse over the page's main "edit" tab link and note the URL has "&oldid=#####" in it, denoting that link would edit an older version and not the current version.
3a. Hover the mouse over the left side's "edit" link and note the URL has an "&oldid=#####" of 1 less than the main page's edit link.
3b. Hover the mouse over the right side's "edit" link and note the URL does not have an "&oldid=#####" at all, implying it is the latest version and, if clicked, would edit the latest version.
4. Click that right side's "edit" link.
5. Edit the page.
6. Save it.
7. Note how your edit merged with the previous edit to become the last edit.

* Actual result: see above
* Expected result: a new edit should be just that--a new edit and not merge with the previous edit
* It's wrong because that's not how editing is supposed to work and changed in MW 1.11.x sometime
Comment 3 Rob Church 2007-08-14 15:02:27 UTC
Behaviour appears to be consistent; "left side" edit link brings up the edit page with the text from that old version, right side brings up current edit page, as it should, and the main "edit this page" link brings up the current edit page too.

All working as it should be.
Comment 4 Eep² 2007-08-14 20:34:21 UTC
Um, have you even tried it, Rob? Edit the right side and save it; your edit will merge with the previous edit... I just edited but, as you can plainly see, your last edit (you added "* [[/Tips]]" to line 34) merged with mine ("** Fix diff editing..." on line 35). Damn is slow today... Well that's didn't do it that time. That is so weird because even no longer shows the combined previous edit anymore. Maybe it's a caching issue? I swear it's been doing this for me for a while now... Ah well...I'll update this if it happens to me again and, hopefully, it'll stay in the page history long enough for someone else to see it...
Comment 5 Rob Church 2007-08-14 21:31:09 UTC
Of course I tried it. I can't see the incorrect behaviour; all the edit links on a standard diff page do what's expected of them.
Comment 6 Eep² 2007-08-21 07:52:27 UTC
OK, it just happened with which I only added the last paragraph but the edit implies I added everything else too.
Comment 7 Rob Church 2007-08-21 16:13:35 UTC
Aha! This isn't a problem with the editor, or the links, it's a problem with the difference engine; I purged the diff provided, and it showed up less changes.

*** This bug has been marked as a duplicate of bug 9112 ***
Comment 8 Eep² 2007-08-21 16:16:32 UTC
A caching issue?

Note You need to log in before you can comment on or make changes to this bug.