Last modified: 2007-06-09 16:19:46 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6743 - Make image links to image page, not to upload on upload disabled [Patch]
Make image links to image page, not to upload on upload disabled [Patch]
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
unspecified
All All
: Normal enhancement with 4 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 6740 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 17:15 UTC by Platonides
Modified: 2007-06-09 16:19 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Linker patch (980 bytes, patch)
2006-07-19 17:39 UTC, Platonides
Details

Description Platonides 2006-07-19 17:15:00 UTC
If a image exist, it's a link to the image page. If a image doesn't exist, the
image link points to the upload page: "be bold and upload it!" Ok. But if you
don't allow uploading, it is unsense. So if a wiki have uploading disabled,
non-existant image links should point to the image page ('we have no such
image') instead of the upload page ('you can't upload, it's disabled') as the
user didn't ask for uploading an image, only followed an image link (which only
wikiholics understand as a link-to-upload).
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2006-07-19 17:19:59 UTC
*** Bug 6740 has been marked as a duplicate of this bug. ***
Comment 2 Platonides 2006-07-19 17:39:27 UTC
Created attachment 2126 [details]
Linker patch

The patch (at r15726). Sorry for the duplicates. Bugzilla wasn't accepting the
post, and was giving 500s. It seems several passed :P
Comment 3 Nicholas Tung 2006-12-29 23:01:43 UTC
I don't know if you patched it incorrectly or what, but when I create a
[[:image:something]] in 1.6.8, it takes me to a "create a new page" instead of
the upload page. I have uploads enabled.
Comment 4 Nicholas Tung 2006-12-29 23:04:08 UTC
I get something like

/index.php?title=Image:imagename&action=edit

that is. if it were without the action=edit, it would work fine.
Comment 5 Rob Church 2007-06-09 16:19:46 UTC
Fixed in r22867.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links