Last modified: 2010-05-15 15:38:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 2128 - even 1.5 gets confused on section editing when <h*> sections are involved
even 1.5 gets confused on section editing when <h*> sections are involved
Status: RESOLVED DUPLICATE of bug 2607
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
1.5.x
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 966 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-10 02:36 UTC by Ævar Arnfjörð Bjarmason
Modified: 2010-05-15 15:38 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ævar Arnfjörð Bjarmason 2005-05-10 02:36:42 UTC
1.4 gets confused on section editing when <h*> sections are involved, if one
creates a page like this:

""""
<h2> Section 1 </h2>
Section 1Section 1Section 1Section 1Section 1
<h2> Section 2 </h2>
Section 2 Section 2 Section 2 Section 2 Section 2 Section 2 
== Section 3 ==
Section 3Section 3Section 3Section 3Section 3Section 3Section 3Section 3
=== Section 4 ===
Section 4Section 4Section 4Section 4Section 4Section 4Section 4Section 4
=== Section 5 ===
Section 5Section 5Section 5Section 5Section 5Section 5Section 5Section 5
=== Section 6 ===
Section 6 Section 6 Section 6 Section 6 Section 6 Section 6
""""

and saves it edit links will appear for sections 3-6 like they should, however
following the edit link for section 3 will bring up an editbox for section 1,
editing section 4 will bring up the box for section 2, 5 for 3 and 6 for 4.
Comment 1 Ævar Arnfjörð Bjarmason 2005-05-10 02:38:21 UTC
See also bug 2129, a section generation bug in 1.5.
Comment 2 Zigger 2005-06-06 13:43:04 UTC

*** This bug has been marked as a duplicate of 966 ***
Comment 3 Ævar Arnfjörð Bjarmason 2005-06-09 21:27:37 UTC
*** Bug 966 has been marked as a duplicate of this bug. ***
Comment 4 Ævar Arnfjörð Bjarmason 2005-06-09 21:29:03 UTC
This was a dupe, but keeping it in favor of bug 996 since it (IMO) does a better
job of explaining the issue.
Comment 5 lɛʁi לערי ריינהארט 2005-06-09 23:41:07 UTC
Halló!

I do not know if this is the same bug which I noticed begining of February 2005.

If you go to
[[eo:Vikipedio:Trukoj/Plurnivela uzado de ŝablonoj#UNDERSCORES]]
end edit the section you will get
http://eo.wikipedia.org/w/index.php?title=Vikipedio:Trukoj/Plurnivela_uzado_de_%C5%9Dablonoj&action=edit&section=25
This is the section above
[[eo:Vikipedio:Trukoj/Plurnivela uzado de ŝablonoj#Helpo rilate - Help regarding
Mediawiki Extensions]]

As far as I remember only id="foo" where used as anchors.

Best regards Reinhardt
Comment 6 Ævar Arnfjörð Bjarmason 2005-06-10 16:07:54 UTC
(In reply to comment #5)
> Halló!
> 
> I do not know if this is the same bug which I noticed begining of February 2005.
> 

Could you reduce it to a simple testcase please.
Comment 7 Zigger 2005-06-10 18:58:09 UTC
(In reply to comment #6)
Opened as bug 2375.
Comment 8 Brion Vibber 2005-06-29 17:41:36 UTC
This is already fixed in 1.5 (section edit links are now generated properly for
these headers). If someone wants to backport the fix to 1.4, feel free to post a
patch, but resolving as FIXED on main branch.
Comment 9 Rowan Collins [IMSoP] 2005-08-06 01:22:00 UTC
Reopening under 1.5, because it's still not handled quite right:
The biggest problem is if the <h*> occurs inside a template, in which case the
section edit link points at the containing article instead of the template, and
all the counting goes up the spout again (since the template has counted one too
few sections, and the containing page one too many). 

But in testing, I noticed that the sections don't nest properly either -
section-editting an "<h3>" section includes a "==" section below it, implying
that "<h3>" comes above, rather than below, "==". 
Comment 10 Rowan Collins [IMSoP] 2005-08-10 12:25:50 UTC
Note: see also bug 2607 (I'm not sure whether to mark these as dupes of one
another, as there seem to be several different issues here)
Comment 11 stux 2006-02-08 06:37:19 UTC

*** This bug has been marked as a duplicate of 2607 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links