Last modified: 2014-02-05 20:21:24 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 11768 - clicking or editing a missing special property page gives no indication that it's special (1.8 alpha)
clicking or editing a missing special property page gives no indication that ...
Status: RESOLVED DUPLICATE of bug 23691
Product: MediaWiki extensions
Classification: Unclassified
Semantic MediaWiki (Other open bugs)
unspecified
All All
: Low minor (vote)
: ---
Assigned To: Markus Krötzsch
http://ontoworld.org/index.php?title=...
:
Depends on: 9748
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 22:55 UTC by S Page
Modified: 2014-02-05 20:21 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description S Page 2007-10-26 22:55:21 UTC
MediaWiki knows if a wiki link exists or not, so if a wiki page links to a missing special property page like [[Property:Equivalent URI]], the link displays in red and on ontoworld.org the link is to &action=edit.

But if you follow the link and start editing there's no indication that the property is special.  The text "This is a special property with a reserved meaning in the wiki" (smw_propertyspecial, see bug 9748) doesn't appear when editing, or when previewing.  It's only when you save that you realize you were editing a special property.

Maybe this is just a fact of life in MediaWiki, or perhaps SMW_PropertyPage can do some of its special handling when the article action is in preview and/or edit mode as well as view.
Comment 1 Jan Schoonderbeek 2012-06-09 04:52:57 UTC
This still seems the case on SMW1.6.1 and 1.8alpha.
Comment 2 MWJames 2014-02-05 20:21:24 UTC

*** This bug has been marked as a duplicate of bug 23691 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links