Last modified: 2007-04-27 17:44:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 9673 - Login rejected even though correct password entered
Login rejected even though correct password entered
Product: MediaWiki
Classification: Unclassified
User login and signup (Other open bugs)
PC Windows XP
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: shell
Depends on:
  Show dependency treegraph
Reported: 2007-04-23 23:47 UTC by Eric Rayner
Modified: 2007-04-27 17:44 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Eric Rayner 2007-04-23 23:47:52 UTC
I tried to log into Wikipedia today---normally I'm automatically logged in, but
that wasn't working.  My browser autoenters my userid+password, but when I
logged in, I was told my password was incorrect.  So I told it to email me a new
password.  I entered the new password but was still told my password was
incorrect.  I tried two different methods to enter the password:
 - cutting and pasting
 - typing in from the keyboard.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-04-23 23:57:10 UTC
1) Remember that passwords are case-sensitive.

2) Make sure you aren't adding any whitespace to the password.

3) Try on a different computer.

4) Give us your username and the exact site (English Wikipedia?) so a sysadmin
can look at your entry in the database and/or try resetting your password manually.
Comment 2 Eric Rayner 2007-04-24 00:24:45 UTC
My Login is InformationSpace.  Case was correct (especially when I cut&paste
from the email).  It was English Wikipedia.

Surely this is a high priority bug as it completely blocks access to account
Comment 3 Aryeh Gregor (not reading bugmail, please e-mail directly) 2007-04-24 00:44:02 UTC
You'll have to wait for a user with shell access to look at your account in the
database, I suppose.  You can expedite the process by hanging around at
irc:// and asking periodically, but there may not
be a sysadmin available at any given time.
Comment 4 Brion Vibber 2007-04-26 18:28:36 UTC
Offhand there doesn't seem to be anything wrong that I can see with the account,
and I have no trouble logging in myself. Try another browser and/or clearing
your browser's password-saving information.
Comment 5 Eric Rayner 2007-04-26 23:27:34 UTC
Clearing the browser's password info wouldn't help when I'm cutting and pasting
the password from email password autogen.  I tried to login yesterday and it
didn't work, but when I tried today it worked fine---no more problem it seems.

This is all very mysterious and suspicious...  I wonder if there is a security
problem here...  Anyway, downgrading priority and severity as there seems to be
no immediate problem any more.

Note You need to log in before you can comment on or make changes to this bug.