Last modified: 2007-01-10 18:22:55 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 8564 - Part of interface remains untranslated when using ?uselang=es
Part of interface remains untranslated when using ?uselang=es
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2007-01-10 06:53 UTC by Titoxd
Modified: 2007-01-10 18:22 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---

Fixed "my preferences" issue (894 bytes, patch)
2007-01-10 07:03 UTC, Titoxd

Description Titoxd 2007-01-10 06:53:41 UTC
Originally I noticed on
that part of the import log interface was not fully translated, particularly the
"$1 revision(s) from $2" part. Then, I noticed that "my preferences" at the top
is not translated either. I then switched my language in [[Special:Preferences]]
to Spanish, and I got the same result. 

I then asked a few other users on #wikipedia-es to tell me if they saw the same,
to remove the possibility of it being a strange artifact of my cache, and all of
them reported the same issue. Then, I went to the English Wikipedia move log,
used ?uselang=es, and got a fully translated interface, with the exception of
"my preferences" again. 

The Spanish Wikipedia correctly displays "mis preferencias", and I cannot find
the place where this error is located. MessagesEs.php looks fine at a glance,
but it's the only culprit that I can imagine.
Comment 1 Titoxd 2007-01-10 07:03:59 UTC
Created attachment 3041 [details]
Fixed "my preferences" issue

Found the "my preferences" bug, but I can't find the others yet.
Comment 2 Rotem Liss 2007-01-10 14:51:37 UTC
The patch was applied by werdna in r19053.

About the other problems: compare the appropriate parts in
languages/messages/MessagesEn.php to the same parts in
languages/messages/MessagesEs.php. In this parts, MessagesEs.php is probably not
complete. See for
information how to complete it. You can use the command line script "php
maintenance/language/checkLanguage.php --lang=es" to see the possible
improvements for MessagesEs.php.
Comment 3 Titoxd 2007-01-10 17:06:48 UTC
That can't be it, because I did compare the two message files side-by-side, and
MessagesEs is complete, at least on that part. The relevant portions are:

'import-logentry-upload' => 'imported [[$1]] by file upload',
'import-logentry-upload-detail' => '$1 revision(s)',
'import-logentry-interwiki' => 'transwikied $1',
'import-logentry-interwiki-detail' => '$1 revision(s) from $2',

'import-logentry-interwiki'	=> 'transwikificada $1',
'import-logentry-interwiki-detail'	=> '$1 revisión/ones desde $2',
'import-logentry-upload'	=> 'importada [[$1]] por subida de archivo',
'import-logentry-upload-detail'	=> '$1 revisión/ones',

That said, when I try
(which includes two entries on the deletion log, one on the protection log, and
another one on the move log), without any modification to the default system
messages, I still get parts of the log entries untranslated. The entries read:

* (Registro de borrados); 07:03 . . Titoxd (Discusión | contribuciones |
bloquear) (deleted "Tito": content was: '#REDIRECT Titoxd' (and the only
contributor was 'Titoxd'))
* (Registro de borrados); 05:08 . . Titoxd (Discusión | contribuciones |
bloquear) (deleted "Titoxd": content was: 'Me.' (and the only contributor was
* (Protecciones de páginas); 05:00 . . Titoxd (Discusión | contribuciones |
bloquear) (protected "Titoxd": semi-protect [edit=autoconfirmed:move=autoconfirmed])
* (Registro de renombrados); 04:35 . . Titoxd (Discusión | contribuciones |
bloquear) (Tito moved to Titoxd: more MediaWiki database tests)

My local copy of MediaWiki is running on SVN HEAD, so having old message files
is not an issue.
Comment 4 Rotem Liss 2007-01-10 18:04:36 UTC
All the "content was: 'Me.' (and the only contributor was 'Titoxd')" stuff uses
the content language (content language is the default language of the site), as
it's an edit summary. About "protected "Titoxd": [...]
[edit=autoconfirmed:move=autoconfirmed]" - it is localised in Special:Log, but
not in Special:Recentchanges: it is stored as an edit summary there, so the
content language is again used. These parts in the interface use the content
language and cannot be localised for the interface language (the interface
langauge is the language set by "uselang=xx" or by the user preference). In
wikis with a content language set to "es", such as ,
these parts are localised. In wikis with another content language set, these
parts use this content language.
Comment 5 Titoxd 2007-01-10 18:12:38 UTC
Yes, but I was expecting "protected", "deleted", "moved to" to be translated, as
they indeed are at
Both of those wikis are set to English, and the messages are translated; the
only one that doesn't work is the Import log message. I realize the edit
summaries are not going to be translated, for obvious reasons, but some of the
system messages that should be translated aren't.
Comment 6 Rotem Liss 2007-01-10 18:17:35 UTC
I don't see the problem. In ,
everything except for the edit summaries ("3 revision(s) from
[[meta:Category:MediaWiki database tables]]") is translated ("X transwikificada Y").
Comment 7 Titoxd 2007-01-10 18:22:55 UTC
Hmm... ok, I see now. I thought those were generated from the interface, not
hardwired as edit summaries. As the patch that fixed the "my preferences" bug is
committed now, I'm closing the bug as FIXED.

Note You need to log in before you can comment on or make changes to this bug.