Last modified: 2010-05-15 15:28:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 749 - parts of the text get duplicated when text exceeds a certain length
parts of the text get duplicated when text exceeds a certain length
Status: CLOSED DUPLICATE of bug 217
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
PC Linux
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2004-10-20 14:23 UTC by Thorsten Maus
Modified: 2010-05-15 15:28 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Thorsten Maus 2004-10-20 14:23:03 UTC
once you add more lines with more text (try 10 lines with at least 20 characters ) 
parts of the complete text get doublicated.
Comment 1 Rowan Collins [IMSoP] 2004-10-20 17:08:06 UTC
How thoroughly odd. Playing around at I
observed two things, neither of which get me any closer to the cause:
1) When the bug is triggered the text of the article is interrupted at some
point (not necessarily at the end) by "wpTextbox1=", or sometimes "%wpTextbox1="
or even "0%wpTextbox1=", followed by the whole of the article text.
2) The trigger doesn't seem to just be a certain length of text: when I first
tried, I successfully stored a page with ~740 chars; with a different layout, I
triggered the bug with ~550 chars. This is consistent with the fact that the
"Bank" article referenced is already longer than this. Clearly, whitespace or
newlines have some kind of effect on whatever is causing this.

There's something vaguely reminiscent here of someone (nick "goatmilk" on IRC, I
think) whose forms simply wouldn't receive any data above a certain size. I
think they solved that now, but I'm not sure how: does anyone know if it turned
out to be a PHP bug or what?
Comment 2 Brion Vibber 2004-10-20 17:49:18 UTC
goatmilk's problem was solved by this change:
includes/EditPage.php?r1=1.122&r2=1.123 as suggested here:

This though sounds like bug 217.
Comment 3 Rowan Collins [IMSoP] 2004-10-20 18:05:14 UTC

*** This bug has been marked as a duplicate of 217 ***
Comment 4 Thorsten Maus 2004-10-21 12:01:50 UTC
an update on the php-version solves this problem .. 

my system now runs with php 4.3.9-1 
and no more problems occur

(In reply to comment #3)
> *** This bug has been marked as a duplicate of 217 ***

Note You need to log in before you can comment on or make changes to this bug.