Last modified: 2014-10-02 08:47:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 71530 - Invalid GROUP BY in SpecialActiveusers
Invalid GROUP BY in SpecialActiveusers
Status: RESOLVED DUPLICATE of bug 68087
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: postgres
  Show dependency treegraph
 
Reported: 2014-10-01 20:28 UTC by Greg Sabino Mullane
Modified: 2014-10-02 08:47 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Greg Sabino Mullane 2014-10-01 20:28:33 UTC
When using a database that requires non-aggregated columns in the GROUP BY (e.g. Postgres), SpecialActiveusers fails because the user_name and user_id columns are brought back unaggregatged, but do not appear in the GROUP BY. The solution is to change SpecialActiveusers.php, inside of getQueryInfo, the abovementioned columns should be added to the GROUP BY array. Alternatively, if this is suboptimal for MySQL, the list of grouped columns should be conditional based on the implicitGroupby property of the database (see for example WikiPage.php).
Comment 1 Jeff Janes 2014-10-02 03:03:10 UTC
This is a duplicate of bug 68087
Comment 2 Andre Klapper 2014-10-02 08:47:12 UTC

*** This bug has been marked as a duplicate of bug 68087 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links