Last modified: 2014-09-11 18:08:33 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 69465 - editing area on MobileFrontend must be set to the language and the direction of the page's content
editing area on MobileFrontend must be set to the language and the direction ...
Status: RESOLVED FIXED
Product: MobileFrontend
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Unprioritized normal
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2014-08-13 12:30 UTC by Amir E. Aharoni
Modified: 2014-09-11 18:08 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2014-08-13 12:30:04 UTC
Editing area in MobileFronted inherits the lang and the dir of the HTML page.

Instead of this it must be explicitly set to the lang and dir of the page.

This causes the editing window to show with the wrong direction if the UI language is changed.
Comment 1 Bingle 2014-08-13 12:30:09 UTC
Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/mVBsrFvV
Comment 3 Amir E. Aharoni 2014-08-13 12:46:30 UTC
... Should be an easy thing to fix, but I know nothing about Hogan. With a bit of advice from experienced MF devs I'll be able to fix it myself.
Comment 4 Juliusz Gonera 2014-08-28 22:29:35 UTC
Is there an easy way to get desired text direction for a page in JS? I know I can get page language easily, but can't find direction among JS variables (unless I use VE variables, but that would mean MF depends on VE).
Comment 5 Amir E. Aharoni 2014-08-28 22:44:19 UTC
On a Wikimedia desktop site I'd use $.uls.data.getDir(). Unfortunately, this is not desktop, not all sites have ULS installed, and the getDir function is not separated from ULS to a more easily reusable library (it really should be).

If it helps, then you can use the dir and lang values of the #content element - https://en.m.wikipedia.org/wiki/ASCII?uselang=he .
Comment 6 Gerrit Notification Bot 2014-08-28 23:15:59 UTC
Change 157002 had a related patch set uploaded by JGonera:
Specify lang and dir for the content in editors

https://gerrit.wikimedia.org/r/157002
Comment 7 Juliusz Gonera 2014-08-29 17:19:20 UTC
*** Bug 70150 has been marked as a duplicate of this bug. ***
Comment 8 Gerrit Notification Bot 2014-09-02 17:39:45 UTC
Change 157002 merged by jenkins-bot:
Specify lang and dir for the content in editors

https://gerrit.wikimedia.org/r/157002
Comment 9 Florian 2014-09-11 18:08:33 UTC
Change merged -> RESOLVED/FIXED

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links