Last modified: 2007-01-13 05:15:49 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 6915 - database move, write doesn't work any more
database move, write doesn't work any more
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
PC Linux
: Low minor (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on:
  Show dependency treegraph
Reported: 2006-08-03 12:46 UTC by Florijn
Modified: 2007-01-13 05:15 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Florijn 2006-08-03 12:46:43 UTC
i moved wiki from a windows xpsp2
MediaWiki: 1.6.7 
PHP: 5.1.4 (apache2handler) 
MySQL: 5.0.22-community-nt 

on to a linux system
MediaWiki: 1.6.7 
PHP: 4.3.10-16 (apache2handler) 
MySQL: 4.0.24_Debian-10sarge1-log 

(i did save the database for version 4)

==Very big problem with wiki, MySQL returned error "1048==
It appears to be fine and I can log in as the admin, but it seems like whenever I try to 
write to the database, like when changing the text on the page, or adding a user, etc., I 
get the following error:

A database query syntax error has occurred. This may indicate a bug in the software. The 
last attempted database query was:

    (SQL query hidden)

from within function "Revision::insertOn". MySQL returned error "1048: Column 'old_id' 
cannot be null (localhost)".
I have researched and tried everything I can think of, but still no luck.

Comment 1 Brion Vibber 2007-01-13 05:15:49 UTC
This sounds like a damaged database; for instance it appears to be missing the
auto_increment setting on text.old_id column.

Probably most likely is due to the way the database was transferred to the older
version of MySQL.

Since this is old and sounds like a problem with the database transferrence, I'm
going to go ahead and close this INVALID.

Note You need to log in before you can comment on or make changes to this bug.