Last modified: 2014-08-13 12:13:45 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 69141 - images are aligned incorrectly in MobileFrontend in RTL
images are aligned incorrectly in MobileFrontend in RTL
Status: RESOLVED FIXED
Product: MobileFrontend
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Unprioritized normal
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2014-08-05 05:54 UTC by Amir E. Aharoni
Modified: 2014-08-13 12:13 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Amir E. Aharoni 2014-08-05 05:54:17 UTC
To reproduce:

Go to https://he.wikipedia.org/wiki/%D7%99%D7%A4%D7%9F#.D7.94.D7.99.D7.A1.D7.98.D7.95.D7.A8.D7.99.D7.94 . This is the "History" section in "Japan". The image "JomonPottery" is correctly placed on the right-hand side.

Go to https://he.m.wikipedia.org/wiki/%D7%99%D7%A4%D7%9F#.D7.94.D7.99.D7.A1.D7.98.D7.95.D7.A8.D7.99.D7.94 using a device with a large screen - tablet or laptop. The same image is incorrectly placed on the left side.
Comment 1 Bingle 2014-08-05 05:55:08 UTC
Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/Zs5uRELl
Comment 2 Brion Vibber 2014-08-05 06:47:11 UTC
Looks like the tleft & tright styles in Minerva are being RTL-flipped in ResourceLoader when they should be left literal. Needs a /* @noflip */ or something?
Comment 3 Gerrit Notification Bot 2014-08-05 07:15:28 UTC
Change 151819 had a related patch set uploaded by Amire80:
Make sure that images are aligned correctly on wide screens

https://gerrit.wikimedia.org/r/151819
Comment 4 Gerrit Notification Bot 2014-08-12 23:29:05 UTC
Change 151819 merged by jenkins-bot:
Make sure that images are aligned correctly on wide screens

https://gerrit.wikimedia.org/r/151819

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links