Last modified: 2014-06-30 08:38:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 65813 - MSSQL installer broken; updateRowExists returns always false
MSSQL installer broken; updateRowExists returns always false
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.24rc
All All
: High major (vote)
: ---
Assigned To: Rainer Rillke @commons.wikimedia
:
Depends on:
Blocks: mssql
  Show dependency treegraph
 
Reported: 2014-05-27 16:25 UTC by Rainer Rillke @commons.wikimedia
Modified: 2014-06-30 08:38 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Rainer Rillke @commons.wikimedia 2014-05-27 16:25:43 UTC
DatabaseUpdater::updateRowExists returns always false because sqlsrv_fetch functions (which is called in the end) doesn't like selecting just 1 and returns false. Similar to http://stackoverflow.com/q/22614335/2683737
Comment 1 Umherirrender 2014-05-27 18:38:47 UTC
This is used also at other places in core (In LocalRepo and LocalFile), but always with the Database::selectField method, maybe it works with that also for MSSQL in the updater? (Different is fetchObject vs. fetchRow).

Just an idea, because selecting 1 is valid sql in my mind.
Comment 2 Rainer Rillke @commons.wikimedia 2014-05-27 19:56:40 UTC
"1 AS X" works in SQLite, MySQL and MSSQL for examle ... I just change the $vars argument to DB::selectRow(); alternatively one could re-implement it in MSSQLUpdater
Comment 3 Gerrit Notification Bot 2014-05-27 22:48:08 UTC
Change 135714 had a related patch set uploaded by Rillke:
Name implicitly created CHECK constraints

https://gerrit.wikimedia.org/r/135714
Comment 4 Andre Klapper 2014-05-28 13:19:43 UTC
Wondering if this only affects 1.24/git master or also 1.23 stable (which might be worth to backport then)?
Comment 5 Rainer Rillke @commons.wikimedia 2014-05-28 16:42:47 UTC
(In reply to Andre Klapper from comment #4)
> Wondering if this only affects 1.24/git master or also 1.23 stable

The issue is there but there's no harm because other checks prevent duplicate execution of the one and only "update rule" present in MssqlUpdater.php in REL1_23
Comment 6 Gerrit Notification Bot 2014-06-30 01:08:47 UTC
Change 135714 merged by jenkins-bot:
Name implicitly created CHECK constraints

https://gerrit.wikimedia.org/r/135714

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links