Last modified: 2014-06-12 06:17:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 65474 - VisualEditor: Template editor is missing accessibility features
VisualEditor: Template editor is missing accessibility features
Status: RESOLVED FIXED
Product: VisualEditor
Classification: Unclassified
Editing Tools (Other open bugs)
unspecified
All All
: Normal normal
: VE-deploy-2014-06-05
Assigned To: Alex Monk
:
: 63014 (view as bug list)
Depends on:
Blocks: 367
  Show dependency treegraph
 
Reported: 2014-05-19 09:19 UTC by Derk-Jan Hartman
Modified: 2014-06-12 06:17 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2014-05-19 09:19:05 UTC
ve-ui-mwParameterPage-actions have tabindex=-1, which makes them unreachable by keyboard, the same for the "Add parameter" button.


The text area of the fields is missing the 'required' attribute for fields that are required.
Comment 1 Gerrit Notification Bot 2014-06-03 20:09:07 UTC
Change 137152 had a related patch set uploaded by Alex Monk:
Add tabindexes to template editor and required attribute where appropriate

https://gerrit.wikimedia.org/r/137152
Comment 2 Gerrit Notification Bot 2014-06-04 23:28:23 UTC
Change 137152 merged by jenkins-bot:
Add tabindexes to template editor and required attribute where appropriate

https://gerrit.wikimedia.org/r/137152
Comment 3 James Forrester 2014-06-12 06:17:48 UTC
*** Bug 63014 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links