Last modified: 2014-06-17 18:52:50 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 63807 - Kerning of Nimbus Sans L could be improved
Kerning of Nimbus Sans L could be improved
Status: RESOLVED WONTFIX
Product: MediaWiki skins
Classification: Unclassified
Vector (Other open bugs)
unspecified
All Linux
: Normal normal
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: typography-refresh
  Show dependency treegraph
 
Reported: 2014-04-11 07:12 UTC by Steven Walling
Modified: 2014-06-17 18:52 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot (235.46 KB, image/png)
2014-04-11 07:31 UTC, Steven Walling
Details

Description Steven Walling 2014-04-11 07:12:18 UTC
Some people are reporting that kerning of Nimbus Sans L could be improved. 

Originally reported by Brian Wolff at http://lists.wikimedia.org/pipermail/wikitech-l/2014-April/075909.html
Comment 1 Steven Walling 2014-04-11 07:13:11 UTC
I did some testing myself in Firefox and Chrome, and I am not really seeing a major issue to be honest. (See attached screenshots).
Comment 2 Steven Walling 2014-04-11 07:19:21 UTC
Decided to upload screenshots to Commons instead. They're at...

[[commons:File:Screenshot of MediaWiki in Chrome with new typography.png]]
[[commons:File:Wikipedia Linux screenshot new typography in Firefox.png]]

Remember that, if you were getting DejaVu Sans before, this is going to look smaller in some respects. We talked about this in bug 63686 as well. DejaVu is a humanist san-serif with much wider appearance to the eye, but vertical x-height is more uniform in a Helvetica-like sans such as Nimbus. This gives us more consistent appearance and readability for large text blocks, which is why it was chosen.
Comment 3 Steven Walling 2014-04-11 07:31:25 UTC
Created attachment 15082 [details]
Screenshot
Comment 4 Steven Walling 2014-04-11 07:32:13 UTC
The additional screenshot I attached is from Chrome on Linux, looking at the same caption Brian reported on. I do not see the same kerning problem he did. Is this potentially browser-specific?
Comment 5 John Mark Vandenberg 2014-04-11 07:49:22 UTC
As I said in a follow up email, the issue is more pronounced in Firefox.  Do you not see it in Firefox?
Comment 6 Bawolff (Brian Wolff) 2014-04-11 12:20:53 UTC
https://commons.wikimedia.org/wiki/File:Typo-refresh-kerning-wn.png

I measured both the fake kerning space and the real space. They were both exactly 3 pixels
Comment 7 Bawolff (Brian Wolff) 2014-04-11 12:23:22 UTC
Oddly enough, chrome on the exact same computer seems to select arial over nimbus (which looks significantly better)
Comment 8 Steven Walling 2014-04-11 16:35:54 UTC
(In reply to Bawolff (Brian Wolff) from comment #7)
> Oddly enough, chrome on the exact same computer seems to select arial over
> nimbus (which looks significantly better)

I assume you downloaded Arial as part of a Windows font package? (Not sure what distro of Linux you are on, but this is somewhat common among Ubuntu users it seems.)
Comment 9 Bawolff (Brian Wolff) 2014-04-11 19:00:28 UTC
I have it. Possibly from wine. Or some other package i installed over the years. Distro is debian
Comment 10 Jared Zimmerman (WMF) 2014-06-17 18:52:50 UTC
We won't be overwriting the kerning to the font, as that would likely cause more issues than it resolves.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links