Last modified: 2014-07-07 08:43:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 63718 - WebFonts is no longer applied to headings (tofus are still shown) after the typography refresh
WebFonts is no longer applied to headings (tofus are still shown) after the t...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UniversalLanguageSelector (Other open bugs)
unspecified
All All
: Unprioritized major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: typography-refresh
  Show dependency treegraph
 
Reported: 2014-04-09 08:36 UTC by Liangent
Modified: 2014-07-07 08:43 UTC (History)
15 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
my.wikipedia screenshot with WebFonts disabled (1.16 MB, image/png)
2014-04-09 08:36 UTC, Liangent
Details
my.wikipedia screenshot with WebFonts enabled (1.52 MB, image/png)
2014-04-09 08:37 UTC, Liangent
Details

Description Liangent 2014-04-09 08:36:13 UTC
It works correctly after I disable the following CSS rule in browser inspector:

div#content h1, div#content h2, div#content #firstHeading {
    font-family: "Linux Libertine",Georgia,Times,serif;
}
Comment 1 Liangent 2014-04-09 08:36:46 UTC
Created attachment 15061 [details]
my.wikipedia screenshot with WebFonts disabled
Comment 2 Liangent 2014-04-09 08:37:07 UTC
Created attachment 15062 [details]
my.wikipedia screenshot with WebFonts enabled
Comment 3 Steven Walling 2014-04-09 09:28:32 UTC
I get the same headings error on a virtual instance of Windows 7 with IE10, Firefox, and Chrome. 

Resetting to "sans-serif" for headings in my Vector.css on mywiki doesn't seem to fix this... Is it for sure related to the new typography stack?
Comment 4 Liangent 2014-04-09 09:43:04 UTC
(In reply to Steven Walling from comment #3)
> I get the same headings error on a virtual instance of Windows 7 with IE10,
> Firefox, and Chrome. 
> 
> Resetting to "sans-serif" for headings in my Vector.css on mywiki doesn't
> seem to fix this... Is it for sure related to the new typography stack?

font-family: sans-serif; doesn't work for me either, but font-family: inherit; works.
Comment 5 Santhosh Thottingal 2014-04-09 11:00:57 UTC
After typography refresh, all headers has  "Linux Libertine, Georgia, Times, serif" as font family style.

ULS webfonts has a policy of not altering any non-generic font-family styles(or explicit font family values) for html elements. Because of this, ULS webfonts is leaving the headers unaffected. 

Since none of the items in the "Linux Libertine, Georgia, Times, serif" stack support my, tofu appears.

This is not a bug in typography refresh, but a case where ULS webfonts needs to update its font applying algorithm and aware of "Linux Libertine, Georgia, Times, serif" stack. It should take the freedom to modify this font stack as a special case.
Comment 6 Jared Zimmerman (WMF) 2014-04-09 18:52:14 UTC
per Santhosh, moving to related, rather than blocking.
Comment 7 Nemo 2014-04-09 18:53:39 UTC
Jared, tracking bugs are used via the "block" field.
Comment 8 Jared Zimmerman (WMF) 2014-04-09 19:03:32 UTC
Thanks Nemo, that a bit confusing, appreciate your help
Comment 9 Gerrit Notification Bot 2014-04-14 10:45:06 UTC
Change 125702 had a related patch set uploaded by Santhosh:
Allow overriding the header styles from typography refresh

https://gerrit.wikimedia.org/r/125702
Comment 10 Gerrit Notification Bot 2014-04-16 09:31:18 UTC
Change 125702 merged by jenkins-bot:
Allow overriding the header styles from typography refresh

https://gerrit.wikimedia.org/r/125702
Comment 11 Jon 2014-04-16 14:38:39 UTC
As stated in my code review on that patch (which seems to have been ignored) this fix is not a long term solution especially with all the instability around font at the moment. Please consider reopening this bug and working on a more long term solution or I guarantee this will bite you again.
Comment 12 Santhosh Thottingal 2014-04-16 16:47:41 UTC
ULS webfonts configuration(jquery.webfonts configuration for MW) is tightly dependent on MW typography. Because it has to handle all kind of language specific font preferences in a wide variety of languages and wikis. It is an extension and works at client side and practically it changes the core fonts applied.

At the same time, it has evolved over time and flexible enough to handle many edge cases of custom font configurations(per wiki configurations, wikisource, wiktionary templates etc). I think it is acceptable to revisit this configuration as mediawiki core typography changes(hopefully it does not change often) and inspect our browser test results. With any typography updates, we are supposed to test the usecases of ULS webfonts across languages
Comment 13 wikimedia.16u 2014-05-01 02:59:47 UTC
When will this be rolled out to WP-en?  It was suggested at [[Talk:Universal Language Selector/WebFonts]] that this may fix the problem I'm having with my display (MS7, FF28), where I can't see text formatted as (for example) Bavarian or Yoruba, and often cannot see section headers even when I can see the text.  I've had this problem ever since trying out automatic font downloading, but reverting that hasn't reverted the problem.
Comment 14 Santhosh Thottingal 2014-05-02 09:52:49 UTC
This fix was rolled out in 1.24/wmf1(https://www.mediawiki.org/wiki/MediaWiki_1.24/wmf1#UniversalLanguageSelector) and already available in WMF wikis.

ULS does not support yo, so what you face with Yoruba might be unrelated to this bug. The typography refresh of MW applies a Serif family font to section headers. It might be the case your local computer does not have a matching font for that.
Comment 15 Nemo 2014-07-07 08:43:18 UTC
(In reply to Santhosh Thottingal from comment #14)
> The typography refresh of MW applies a Serif family font to
> section headers. It might be the case your local computer does not have a
> matching font for that.

Similar problem in bug 56939 comment 42 for ur.wiki?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links