Last modified: 2014-04-22 22:08:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 62073 - Flow: Small view and "This topic hidden" titlebars are misaligned after typography refresh
Flow: Small view and "This topic hidden" titlebars are misaligned after typo...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Flow (Other open bugs)
master
All All
: High normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 64193 (view as bug list)
Depends on:
Blocks: typography-refresh
  Show dependency treegraph
 
Reported: 2014-02-28 20:58 UTC by spage
Modified: 2014-04-22 22:08 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Flow screenshot of misaligned titlebar of deleted topic (20.60 KB, image/png)
2014-04-21 18:20 UTC, spage
Details
bad text positioning of h2 in button titlebar in Small view (24.01 KB, image/png)
2014-04-22 00:34 UTC, spage
Details

Description spage 2014-02-28 20:58:03 UTC
If you enable the Typography refresh beta feature and visit a Flow page, the  "This topic was hidden by" text is misaligned vertically, appearing very low with descenders appearing outside the titlebar. See http://imgur.com/lLcMMyG .

Whether Flow should use h2 in titlebar and how much it should override h2 styling are open issues, see bug 59636.
Comment 1 spage 2014-03-05 19:57:55 UTC
Need to retest with Gerrit change #116474 patch for bug 59636 which changes how posts render topic titlebar.
Comment 2 spage 2014-04-21 18:17:53 UTC
*** Bug 64193 has been marked as a duplicate of this bug. ***
Comment 3 spage 2014-04-21 18:20:33 UTC
Created attachment 15147 [details]
Flow screenshot of misaligned titlebar of deleted topic
Comment 4 spage 2014-04-22 00:33:01 UTC
Also small view (the third icon) is messed up on mediawiki.org for both Firefox and chromium; I assume that's part of the same bug.  It's not so bad on enwiki, so something in Flow or headers or button styling seems to be in 1.24 that wasn't in 1.23wmf22.
Comment 5 spage 2014-04-22 00:34:59 UTC
Created attachment 15154 [details]
bad text positioning of h2 in button titlebar in Small view
Comment 6 Gerrit Notification Bot 2014-04-22 01:53:26 UTC
Change 127858 had a related patch set uploaded by SG:
Fix topic hidden message when collapsed

https://gerrit.wikimedia.org/r/127858
Comment 7 Gerrit Notification Bot 2014-04-22 12:30:37 UTC
Change 127858 merged by jenkins-bot:
Fix topic hidden message when collapsed

https://gerrit.wikimedia.org/r/127858
Comment 8 Gerrit Notification Bot 2014-04-22 12:36:55 UTC
Change 127903 had a related patch set uploaded by Matthias Mullie:
Fix topic hidden message when collapsed

https://gerrit.wikimedia.org/r/127903
Comment 9 Gerrit Notification Bot 2014-04-22 12:37:43 UTC
Change 127903 merged by jenkins-bot:
Fix topic hidden message when collapsed

https://gerrit.wikimedia.org/r/127903
Comment 10 spage 2014-04-22 22:08:27 UTC
Fixed and backported to 1.24wmf1.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links