Last modified: 2014-04-06 01:12:21 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 60594 - MediaWiki:Watchnologintext needs returnto parameter
MediaWiki:Watchnologintext needs returnto parameter
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Watchlist (Other open bugs)
1.23.0
All All
: Normal normal (vote)
: 1.23.0 release
Assigned To: Konarak Ratnakar
https://www.mediawiki.org/wiki/Reques...
: easy, i18n
Depends on:
Blocks: messages 54730
  Show dependency treegraph
 
Reported: 2014-01-29 20:46 UTC by Nemo
Modified: 2014-04-06 01:12 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nemo 2014-01-29 20:46:59 UTC
If I visit action=watch logged out, I get:

----

You must be <a href="/wiki/Special:UserLogin" title="Special:UserLogin">logged in</a> to modify your watchlist.

Return to <a href="/wiki/MediaWiki" title="MediaWiki">MediaWiki</a>.

----

The Special:UserLogin URL should include a returnto parameter so that after logging in/registering the user can at least get back to the original page.
Comment 1 Nemo 2014-01-29 21:04:38 UTC
I hope that the "Return to MediaWiki" part doesn't mean the title= parameter is being ignored completely (so that it defaults to the main page) just because the token is absent or something. In that case, things might be trickier.
Comment 2 Severino Mizael 2014-02-27 18:44:29 UTC
Returnto is to send you to a specific page. not to perform an action.
read http://www.mediawiki.org/wiki/User:S_Page_(WMF)/Return_to

maybe this is not a bug.
Comment 3 Nemo 2014-02-28 07:43:14 UTC
(In reply to Severino Mizael from comment #2)
> Returnto is to send you to a specific page. not to perform an action.
> read http://www.mediawiki.org/wiki/User:S_Page_(WMF)/Return_to

I read it, but it didn't say anything new to me. :) I don't understand your comment, I'm asking returnto to contain a specific page i.e. the page one was in (this is the standard usage), not "to perform an action".
Comment 4 Severino Mizael 2014-02-28 11:35:59 UTC
I was wrong earlier. 
Now I see that if you use the "log in" option at the top right of the page Returnto works correctly. But if you use this "You must be logged in to modify your watchlist" does not work. 

I'll try solve again.
Comment 5 Gerrit Notification Bot 2014-03-30 03:08:47 UTC
Change 122089 had a related patch set uploaded by Konarak:
MediaWiki:Watchnologintext: Add returnto parameter

https://gerrit.wikimedia.org/r/122089
Comment 6 Gerrit Notification Bot 2014-04-04 08:38:43 UTC
Change 123837 had a related patch set uploaded by Konarak:
MediaWiki:Watchnologintext: Add returnto parameter

https://gerrit.wikimedia.org/r/123837
Comment 7 Gerrit Notification Bot 2014-04-04 08:40:11 UTC
Change 122089 abandoned by Konarak:
MediaWiki:Watchnologintext: Add returnto parameter

Reason:
New patch set at https://gerrit.wikimedia.org/r/123837

https://gerrit.wikimedia.org/r/122089
Comment 8 Bartosz Dziewoński 2014-04-04 11:19:58 UTC
(In reply to Nemo from comment #1)
> I hope that the "Return to MediaWiki" part doesn't mean the title= parameter
> is being ignored completely (so that it defaults to the main page) just
> because the token is absent or something. In that case, things might be
> trickier.

No, the user will just have to confirm the action by clicking "OK" one more time. You can test it by looking at e.g. <https://en.wikipedia.org/w/index.php?title=Main_Page&action=watch> (the link has no token on it, obviously).
Comment 9 Bartosz Dziewoński 2014-04-06 01:11:13 UTC
Thanks for the patch!
Comment 10 Gerrit Notification Bot 2014-04-06 01:12:21 UTC
Change 123837 merged by jenkins-bot:
WatchAction: Add 'returnto' and 'returntoquery' to the login link

https://gerrit.wikimedia.org/r/123837

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links