Last modified: 2014-01-14 06:09:14 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 59999 - Installer fails with mysql error (only PHP PDO + sqlite3 are present)
Installer fails with mysql error (only PHP PDO + sqlite3 are present)
Status: RESOLVED DUPLICATE of bug 58167
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.22.0
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-13 14:23 UTC by walter
Modified: 2014-01-14 06:09 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description walter 2014-01-13 14:23:43 UTC
On the 'Connect to database' step, the installer fails with a MySQL related error even though MySQL is not relevant since only PHP PDO and sqlite3 are present on the system and the intention is to use SQLite3. Documentation suggests this is a fairly standard configuration that should be fully supported by the installer.

[6d919bda] /wiki/mw-config/index.php?page=DBConnect Exception from line 788 of /var/www/localhost/htdocs/mediawiki-1.22.0/includes/db/Database.php: DatabaseBase::factory no viable database extension found for type 'mysql'

Backtrace:

#0 /var/www/localhost/htdocs/mediawiki-1.22.0/includes/installer/WebInstallerPage.php(487): DatabaseBase::factory(string)
#1 /var/www/localhost/htdocs/mediawiki-1.22.0/includes/installer/WebInstaller.php(275): WebInstaller_DBConnect->execute()
#2 /var/www/localhost/htdocs/mediawiki-1.22.0/mw-config/index.php(61): WebInstaller->execute(array)
#3 /var/www/localhost/htdocs/mediawiki-1.22.0/mw-config/index.php(29): wfInstallerMain()
#4 {main}
Comment 1 Andre Klapper 2014-01-13 14:43:45 UTC
Thanks for taking the time to report this!

This will be fixed in 1.22.1.

*** This bug has been marked as a duplicate of bug 58167 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links