Last modified: 2013-12-20 15:54:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 58735 - When MySQL is not installed, an Exception blocks the installation
When MySQL is not installed, an Exception blocks the installation
Status: RESOLVED DUPLICATE of bug 58167
Product: MediaWiki
Classification: Unclassified
Installer (Other open bugs)
1.22.0
PC Linux
: High major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-20 09:38 UTC by caron
Modified: 2013-12-20 15:54 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description caron 2013-12-20 09:38:58 UTC
I wanted to use SQLite as the database engine, and MySQL is not installed on my machine. When I ran the installer, at the "Connect to database" step, I got the following exception:

[9bb13ddd] /mw-config/index.php?page=DBConnect Exception from line 788 of /home/mediawiki/wiki/includes/db/Database.php: DatabaseBase::factory no viable database extension found for type 'mysql'

Backtrace:

#0 /home/mediawiki/wiki/includes/installer/WebInstallerPage.php(487): DatabaseBase::factory(string)
#1 /home/mediawiki/wiki/includes/installer/WebInstaller.php(275): WebInstaller_DBConnect->execute()
#2 /home/mediawiki/wiki/mw-config/index.php(61): WebInstaller->execute(array)
#3 /home/mediawiki/wiki/mw-config/index.php(29): wfInstallerMain()
#4 {main}

I needed to comment lines 94-96 in includes/installer/Installer.php in order to continue the installation, i.e.,

        protected static $dbTypes = array( 
                //'mysql', 
                //'postgres', 
                //'oracle', 
                'sqlite', 
        );

Shouldn't MediaWiki have detected that MySQL was not installed, or asked me what type of RDBMS I wanted to use?
Comment 1 Jesús Martínez Novo (Ciencia Al Poder) 2013-12-20 15:54:54 UTC

*** This bug has been marked as a duplicate of bug 58167 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links