Last modified: 2013-12-02 14:02:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 57789 - "/" string suffix shown at the end in a style="text-align:left" section on RTL wiki
"/" string suffix shown at the end in a style="text-align:left" section on RT...
Status: RESOLVED INVALID
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.23.0
PC Linux
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2013-12-01 06:39 UTC by omid
Modified: 2013-12-02 14:02 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Slash Chracter in RTL WIki (234.90 KB, image/png)
2013-12-01 06:39 UTC, omid
Details

Description omid 2013-12-01 06:39:31 UTC
Created attachment 13948 [details]
Slash Chracter in RTL WIki

suppose I want to write "/hello" Left-to-Right in a RTL wiki:

<div style="text-align:left">/hello </div>

but the result is this:

hello/

Slash character doesn't show properly.
Comment 1 Andre Klapper 2013-12-02 10:35:06 UTC
Thanks for taking the time to report this!

Confirmed by pasting the above line on https://ar.wikipedia.org/w/index.php?title=%D9%86%D9%82%D8%A7%D8%B4_%D8%A7%D9%84%D9%85%D8%B3%D8%AA%D8%AE%D8%AF%D9%85:AKlapper_%28WMF%29/bug57789 in preview mode.
Comment 2 Derk-Jan Hartman 2013-12-02 11:36:12 UTC
but shouldn't it be <div style="text-align:left;" dir="ltr">/hello </div>

in that case ? How would bidi now it's an ltr text otherwise ?
Comment 3 Siebrand Mazeland 2013-12-02 12:14:51 UTC
I think this is an invalid report. I think that directionality hints and browser specific implementations of the bi-directional text algorithms depend how this is rendered.

Will ask Amir to assess.
Comment 4 Amir E. Aharoni 2013-12-02 12:33:29 UTC
(In reply to comment #2)
> but shouldn't it be <div style="text-align:left;" dir="ltr">/hello </div>
> 
> in that case ? How would bidi now it's an ltr text otherwise ?

If I understand the report correctly the right thing to do is to use
<div lang="en" dir="ltr" class="mw-content-ltr">/hello</div>

style="text-align:left" is not supposed to be needed if you use the above attributes.

Please reopen if Derk-Jan and I misunderstand something.
Comment 5 omid 2013-12-02 13:56:59 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > but shouldn't it be <div style="text-align:left;" dir="ltr">/hello </div>
> > 
> > in that case ? How would bidi now it's an ltr text otherwise ?
> 
> If I understand the report correctly the right thing to do is to use
> <div lang="en" dir="ltr" class="mw-content-ltr">/hello</div>
> 
> style="text-align:left" is not supposed to be needed if you use the above
> attributes.
> 
> Please reopen if Derk-Jan and I misunderstand something.

It worked, Thanks
Comment 6 Andre Klapper 2013-12-02 14:01:27 UTC
There was no valid bug in existing MediaWiki code here, hence nothing was FIXED either. Resetting to INVALID.
Comment 7 Siebrand Mazeland 2013-12-02 14:02:30 UTC
Mid-air collision with explanation:

Updating the resolution back to the original "invalid". Per https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle :

* RESOLVED INVALID when the problem is not a bug.
* RESOLVED FIXED when a code change that fixes the reported problem has been merged in Gerrit.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links