Last modified: 2013-11-21 09:41:16 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 56358 - plain text email notification includes HTML footer
plain text email notification includes HTML footer
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
Echo (Other open bugs)
unspecified
All All
: Unprioritized normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 57255 (view as bug list)
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2013-10-30 00:28 UTC by John Mark Vandenberg
Modified: 2013-11-21 09:41 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description John Mark Vandenberg 2013-10-30 00:28:30 UTC
When 'plain text' is selected in preferences, the following is included in the email:

<span lang="en" dir="ltr">Wikimedia Foundation, 149 New Montgomery St., 3rd Fl., San Francisco, CA 94105 (USA).</span>

The change was this recent commit:

https://gerrit.wikimedia.org/r/#/c/90934/2/wmf-config/InitialiseSettings.php,unified
Comment 1 spage 2013-10-31 17:01:33 UTC
The WMF core features team tracks this bug on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/391, but people from the community are welcome to contribute here and in Gerrit.
Comment 2 Siebrand Mazeland 2013-11-06 16:29:47 UTC
It's not only when plain text is selected. The multi type message with HTML also has a text version that displays the HTML as plain text.
Comment 3 Amir E. Aharoni 2013-11-06 16:39:59 UTC
It can be resolved in a simplistic way by changing the value to "Wikimedia Foundation, 149 New Montgomery St., 3rd Fl., San Francisco, CA 94105, USA". Without any punctuation in the beginning and the end, there won't be any RTL issues.

If there is a way to have different values for text emails and for HTML emails, then the text email should have this simple text without punctuation in the end and the HTML should have the proper HTML tags.

Another possibility is to add the LRM character (U+200E) in the end.
Comment 4 Kunal Mehta (Legoktm) 2013-11-19 16:44:18 UTC
*** Bug 57255 has been marked as a duplicate of this bug. ***
Comment 5 Gerrit Notification Bot 2013-11-19 22:55:40 UTC
Change 96392 had a related patch set uploaded by Bsitu:
Remove html tag from echo email footer address

https://gerrit.wikimedia.org/r/96392
Comment 6 Gerrit Notification Bot 2013-11-20 22:17:10 UTC
Change 96392 merged by Bsitu:
Remove html tag from echo email footer address

https://gerrit.wikimedia.org/r/96392

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links