Last modified: 2014-02-12 23:52:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 53103 - Mobile "Upload" button needs RTL adjustment
Mobile "Upload" button needs RTL adjustment
Status: RESOLVED FIXED
Product: MobileFrontend
Classification: Unclassified
stable (Other open bugs)
unspecified
All All
: Unprioritized normal
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: rtl
  Show dependency treegraph
 
Reported: 2013-08-20 17:26 UTC by Osama
Modified: 2014-02-12 23:52 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Arabic Special:Uploads interace (10.02 KB, image/png)
2013-08-20 17:26 UTC, Osama
Details

Description Osama 2013-08-20 17:26:50 UTC
Created attachment 13134 [details]
Arabic Special:Uploads interace

In the mobile version of Special:Uploads, the "Contribute an image" button needs an adjustment to work with RTL interfaces. See the attached screenshot.
Comment 1 Brion Vibber 2013-08-20 18:02:59 UTC
For reference, what device/browser is this?
Comment 2 Osama 2013-08-20 18:15:53 UTC
I can confirm the issue on Firefox Mobile and Chrome for Mobile in all RTL languages.  But the screenshot is actually from my laptop.
Comment 3 Brion Vibber 2013-08-20 18:22:05 UTC
Can confirm also on Safari / iOS 6.1.3. Looks like the spacing border is adjusted for RTL, but the icon positioning isn't. Needs to be flipped from left to right side.
Comment 4 Jon 2013-08-20 18:23:43 UTC
Thanks for pointing this out to us Osama!
Comment 5 Gerrit Notification Bot 2013-08-23 19:59:41 UTC
Change 80656 had a related patch set uploaded by Jdlrobson:
Bug 53103: Apply RTL styling for upload button

https://gerrit.wikimedia.org/r/80656
Comment 6 Gerrit Notification Bot 2013-08-26 16:48:39 UTC
Change 80656 merged by jenkins-bot:
Bug 53103: Apply RTL styling for upload button

https://gerrit.wikimedia.org/r/80656

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links