Last modified: 2014-02-12 23:52:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 53086 - Mobile rendering improperly omits space after reference and before wikilink
Mobile rendering improperly omits space after reference and before wikilink
Status: RESOLVED FIXED
Product: MobileFrontend
Classification: Unclassified
stable (Other open bugs)
unspecified
All All
: Unprioritized minor
: ---
Assigned To: Max Semenik
:
: 53418 54171 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-20 04:45 UTC by Harold Tessmann III
Modified: 2014-02-12 23:52 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshots showing all three rendered examples in desktop Safari (767.38 KB, image/png)
2013-08-20 04:45 UTC, Harold Tessmann III
Details

Description Harold Tessmann III 2013-08-20 04:45:03 UTC
Created attachment 13132 [details]
Screenshots showing all three rendered examples in desktop Safari

1. On the mobile site <http://en.m.wikipedia.org/>, view a page with a reference tag immediately before a Wikilink. Note that the tag does not have a space between the reference callout number and the following Wikilink.
2. View the same page on the desktop site <http://en.wikipedia.org/wiki/> and note that the same tag _does_ have a space between the reference callout number and the following Wikilink.
3. Edit the page, find the tag in question, and confirm that the source does have the space.

Examples:
<http://en.m.wikipedia.org/wiki/Dads>, under heading "Development and production", subheading "Casting":
	whose father Crawford moves in with him.[7]Peter Riegert was then added 
	Edna, Eli's hard-drinking, outspoken maid.[10]Seth Green and Erin Pineda 

<http://en.wikipedia.org/wiki/Dads>:
	whose father Crawford moves in with him.[7] Peter Riegert was then added
	Edna, Eli's hard-drinking, outspoken maid.[10] Seth Green and Erin Pineda


<http://en.m.wikipedia.org/wiki/Clare_Grant>, under heading "Career", subheading "Television work":
	She does voices on Robot Chicken,[1]MAD & originated a bounty hunter

<http://en.wikipedia.org/wiki/Clare_Grant>
	She does voices on Robot Chicken,[1] MAD & originated a bounty hunter


<http://en.m.wikipedia.org/wiki/Husbands_(sitcom)>, under heading "Production", subheading "Casting":
	Amber Benson, Emma Caulfield,[16]Tricia Helfer, Sasha Roiz,
	Aasha Davis, Clare Grant,[17]Jon Cryer and Mekhi Phifer.
	
<http://en.wikipedia.org/wiki/Husbands_(sitcom)>
	Amber Benson, Emma Caulfield,[16] Tricia Helfer, Sasha Roiz,
	Aasha Davis, Clare Grant,[17] Jon Cryer and Mekhi Phifer.


See attached screenshot for rendered examples in desktop Safari.

Tested with a recent version of Mobile Safari, desktop Safari 6.0.5 (8536.30.1), and Firefox 17.0.8 (OS X). All exhibit the same behavior.
Comment 1 Andre Klapper 2013-08-20 09:55:49 UTC
Thanks for taking the time to report this!
Confirming on http://en.m.wikipedia.org/wiki/Dads with Firefox 23.
Comment 2 Jon 2013-08-20 18:36:36 UTC
Mmm.. it seems that the wikitext has a space between the link and the reference - is this an issue with the parser? The references look fine when they are not followed by a link.

Adding styling to the reference itself would result in a larger space when a link doesn't follow. Andre - who's best to comment on whether this is a parser bug and not a MobileFrontend one?
Comment 3 Jon 2013-08-26 20:54:44 UTC
Really confused why this doesn't effect desktop. Maybe something to do with our formatter hacks?
Comment 4 Jon 2013-08-26 20:55:07 UTC
ie. use of DOMParse.. ? Max any thoughts..?
Comment 5 Jon 2013-08-27 20:01:01 UTC
*** Bug 53418 has been marked as a duplicate of this bug. ***
Comment 6 Gerrit Notification Bot 2013-08-28 16:08:03 UTC
Change 81507 had a related patch set uploaded by MaxSem:
Fix spaces after references

https://gerrit.wikimedia.org/r/81507
Comment 7 Gerrit Notification Bot 2013-09-05 17:06:26 UTC
Change 81507 merged by jenkins-bot:
Fix spaces after references

https://gerrit.wikimedia.org/r/81507
Comment 8 Jon 2013-09-16 17:21:15 UTC
*** Bug 54171 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links