Last modified: 2013-12-11 23:30:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 52868 - Add LIMIT/ORDER BY options to Database delete wrapper
Add LIMIT/ORDER BY options to Database delete wrapper
Status: RESOLVED DUPLICATE of bug 26682
Product: MediaWiki
Classification: Unclassified
Database (Other open bugs)
1.22.0
All All
: Low enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 22:27 UTC by Sam Reed (reedy)
Modified: 2013-12-11 23:30 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Sam Reed (reedy) 2013-08-14 22:27:23 UTC
public function delete( $table, $conds, $fname = __METHOD__ ) {

https://dev.mysql.com/doc/refman/5.0/en/delete.html
https://www.sqlite.org/lang_delete.html

It'd be useful to have things LIMIT (for batched queries) or ORDER BY.

Should be fairly trivially done, following options for update/select etc
Comment 1 Chad H. 2013-08-14 23:57:17 UTC
This only works on MySQL and Sqlite as far as I can tell :\
Comment 2 Sam Reed (reedy) 2013-12-11 23:30:37 UTC

*** This bug has been marked as a duplicate of bug 26682 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links