Last modified: 2014-05-20 21:28:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 51918 - VisualEditor: Change tab order in save dialog to be more like the wikitext editor's save form
VisualEditor: Change tab order in save dialog to be more like the wikitext ed...
Status: RESOLVED FIXED
Product: VisualEditor
Classification: Unclassified
MediaWiki integration (Other open bugs)
unspecified
All All
: High minor
: VE-deploy-2013-10-10
Assigned To: Rob Moen
: accessibility
: 52080 53257 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 01:48 UTC by MZMcBride
Modified: 2014-05-20 21:28 UTC (History)
13 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description MZMcBride 2013-07-24 01:48:28 UTC
Cloning from bug 50897 comment 2:

In the old editor, I would simply use TAB to reach the edit summary, type my
edit summary and press ENTER to activate the "Save page" button and save. If I
wanted to mark the edit minor, then I could type my edit summary, press TAB,
SPACE, and then ENTER to "Save page".

I can see that the new box for entering an edit summary allows newlines to be
entered. I am not sure this is a good idea, because I just used a WSYIWYG
editor and now "What I see" - well-formatted paragraphs describing my edit - is
not going to be "what I get" - everything smashed on one line in the article
history. But that is perhaps grist for another bug mill.

It seems that the "Save page" button never receives caret focus if I use TAB to
try to get there. This would seem to have accessibility ramifications.
Comment 1 MZMcBride 2013-07-24 01:50:02 UTC
Yeah, VisualEditor is kind of disruptive in this way. I'd like some further thought here.
Comment 2 John Mark Vandenberg 2013-07-24 01:53:14 UTC
That is an enhancement MZMcBride.

*** This bug has been marked as a duplicate of bug 50047 ***
Comment 3 James Forrester 2013-07-26 23:20:15 UTC
*** Bug 52080 has been marked as a duplicate of this bug. ***
Comment 4 Chris McKenna 2013-08-02 09:28:49 UTC
There has been a slight change to this recently but it is still wrong.

Current behaviour: Pressing tab from the summary box leads to the minor edit link
Desired behaviour: It should lead to the minor edit checkbox (not the link)
Comment 5 Chris McKenna 2013-08-16 08:53:29 UTC
Dcoetzee at en.wp reports that the tab order differs in different browsers, and that at a certain point in firefox the focus gets stuck and neither tab nor shift-tab can move it.

The full comment is below:
    "On Chrome Version 28.0.1500.95 m on Windows 7 x64: It starts in the edit summary field, goes to the "minor edit" link (not the checkbox), then the Save page button, then the Review your changes button (moving right to left), then the three links in the small text at the bottom, then the address bar, then the Search box, then the minor edit checkbox, then the "Interactions" menu drop down on the left sidebar (???), then the Watch this page checkbox. If I use SHIFT+TAB it goes to Edit summary link, then jumps straight to the Mediawiki logo way in the bottom right.

    On Firefox 22.0 and 23.0 on Windows 7 x64: It starts in the edit summary field, goes to the "minor edit" link (not the checkbox), then the Save page button, then thereafter neither TAB nor SHIFT+TAB do anything (focus is stuck - this is a serious problem as it may require reloading the page and losing edits). SHIFT+TAB is same as in Chrome.

Conventionally, tab order is supposed to go in a logical reading order: left-to-right, top-to-bottom. My expected order was something like this:

    Starts in edit summary field, goes to minor edit checkbox, then minor edit link, then Watch this page checkbox, then Review your changes button, then Save page button, then the three links at the bottom. If I use SHIFT+TAB to tab backwards, I expect to visit the Edit summary link, then (if possible) the arrow to collapse/abort the Save, then the Search box."
Comment 6 James Forrester 2013-09-03 22:26:29 UTC
*** Bug 53257 has been marked as a duplicate of this bug. ***
Comment 7 Gerrit Notification Bot 2013-09-04 20:13:40 UTC
Change 81876 had a related patch set uploaded by Jforrester:
Make the save dialog an actual dialog

https://gerrit.wikimedia.org/r/81876
Comment 8 Gerrit Notification Bot 2013-10-07 23:01:57 UTC
Change 81876 merged by jenkins-bot:
Make the save dialog an actual dialog

https://gerrit.wikimedia.org/r/81876
Comment 9 James Forrester 2013-10-07 23:04:08 UTC
The fix for this is now merged and will be deployed on Thursday 10 October to MediaWiki.org, and to Wikipedias on Thursday 17 October.
Comment 10 James Forrester 2014-04-21 17:42:37 UTC
*** Bug 53257 has been marked as a duplicate of this bug. ***
Comment 11 Luis Villa (personal-for work use lvilla@wikimedia.org) 2014-05-20 19:56:51 UTC
This is broken (again?) The three license links come up before the action buttons (and save page never comes up, but that is bug 50047 I think?)
Comment 12 James Forrester 2014-05-20 21:05:50 UTC
(In reply to Luis Villa (personal-for work use lvilla@wikimedia.org) from comment #11)
> This is broken (again?) The three license links come up before the action
> buttons (and save page never comes up, but that is bug 50047 I think?)

Was going to re-open, but because it's a browser-specific issue I've instead opened bug 65554 to get this fixed.
Comment 13 Luis Villa (personal-for work use lvilla@wikimedia.org) 2014-05-20 21:28:12 UTC
At least for me, this is not browser-specific: I get the problem in both Chrome and FFox. (The other problem is, I agree, browser-specific.)

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links