Last modified: 2014-06-09 16:50:12 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 50897 - VisualEditor: Ctrl-Alt-s / ⌘-Opt-s should trigger the save dialog, and the save button when inside said dialog
VisualEditor: Ctrl-Alt-s / ⌘-Opt-s should trigger the save dialog, and the sa...
Status: RESOLVED FIXED
Product: VisualEditor
Classification: Unclassified
Editing Tools (Other open bugs)
unspecified
All All
: Normal enhancement
: VE-deploy-2014-02-20
Assigned To: Alex Monk
: accessibility
: 52745 53693 (view as bug list)
Depends on:
Blocks: ve-keyboardshortcuts
  Show dependency treegraph
 
Reported: 2013-07-07 20:27 UTC by Derk-Jan Hartman
Modified: 2014-06-09 16:50 UTC (History)
14 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Derk-Jan Hartman 2013-07-07 20:27:43 UTC
In the old editor, you could hit ctrl-alt-s to save the page. In the new editor the save action is not reachable using the keyboard.

We could just add ctrl-s/cmd-s to the Save button ?
Comment 1 James Forrester 2013-07-07 21:00:13 UTC
I think taking over ctrl-s/⌘-s which is already used by every browser for a different task (local save of rendered HTML) is a bit rude; I'd suggest just implementing the same keyboard shortcut.
Comment 2 sk8er_97456 2013-07-10 18:21:35 UTC
In the old editor, I would simply use TAB to reach the edit summary, type my edit summary and press ENTER to activate the "Save page" button and save. If I wanted to mark the edit minor, then I could type my edit summary, press TAB, SPACE, and then ENTER to "Save page".

I can see that the new box for entering an edit summary allows newlines to be entered. I am not sure this is a good idea, because I just used a WSYIWYG editor and now "What I see" - well-formatted paragraphs describing my edit - is not going to be "what I get" - everything smashed on one line in the article history. But that is perhaps grist for another bug mill.

It seems that the "Save page" button never receives caret focus if I use TAB to try to get there. This would seem to have accessibility ramifications.
Comment 3 Chris McKenna 2013-07-21 14:35:51 UTC
This seems similar to bug 38042. They're not identical but definitely related and they could possibly be usefully fixed at the same time.
Comment 4 MZMcBride 2013-07-24 01:50:51 UTC
(In reply to comment #2)
> In the old editor, I would simply use TAB to reach the edit summary, type my
> edit summary and press ENTER to activate the "Save page" button and save. If
> I wanted to mark the edit minor, then I could type my edit summary, press TAB,
> SPACE, and then ENTER to "Save page".

Yeah... I split this out to bug 51918.
Comment 5 John Broughton 2013-07-24 17:46:26 UTC
Having shortcuts for Show preview/Review your changes, and for Save page (two different buttons, so if one shortcut is used for both, VE needs to check whether it is on the main page or in a dialog box), would certainly be helpful. To quote the WMF Deputy Director: "It's worth noting that VisualEditor has its own set of keyboard shortcuts, which can help with common tasks such as linking (which I actually already find faster in VE) ..."

And yes, there is also the accessibility issue - anything that can *only* be done by mouse is, by definition, an immovable problem to a physically disabled person who can only use a keyboard.
Comment 6 James Forrester 2013-08-29 22:14:30 UTC
*** Bug 52745 has been marked as a duplicate of this bug. ***
Comment 7 James Forrester 2013-09-03 15:56:59 UTC
*** Bug 53693 has been marked as a duplicate of this bug. ***
Comment 8 WhatamIdoing 2013-09-09 21:35:22 UTC
I don't have any particularly strong views about the right way to do this, but I really want to be able to open the page in VisualEditor, make a small change to the text, and save the page, without ever taking my hands off the keyboard.
Comment 9 Alex Monk 2014-01-30 18:55:56 UTC
Trying to use accesskey=s like action=edit will make this conflict with FlaggedRevs, which doesn't appear on action=edit but does on veaction=edit (with display:none).
Comment 10 Gerrit Notification Bot 2014-01-30 19:39:36 UTC
Change 110434 had a related patch set uploaded by Alex Monk:
Use accesskey=s on the save buttons

https://gerrit.wikimedia.org/r/110434
Comment 11 Gerrit Notification Bot 2014-02-14 01:48:01 UTC
Change 113319 had a related patch set uploaded by Alex Monk:
Add save shortcut to dialog

https://gerrit.wikimedia.org/r/113319
Comment 12 Gerrit Notification Bot 2014-02-14 16:51:39 UTC
Change 113319 abandoned by Esanders:
Add save shortcut to dialog

Reason:
ALT+S is MediaWiki only, abandoning in favour of Idf4fa31b98d1fa9e

https://gerrit.wikimedia.org/r/113319
Comment 13 Gerrit Notification Bot 2014-02-19 21:42:16 UTC
Change 110434 merged by jenkins-bot:
Use accesskey=s on the save buttons

https://gerrit.wikimedia.org/r/110434

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links