Last modified: 2013-10-29 07:39:29 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 50566 - VisualEditor: Bad typing/backspacing behaviour for Malayalam
VisualEditor: Bad typing/backspacing behaviour for Malayalam
Status: RESOLVED WORKSFORME
Product: VisualEditor
Classification: Unclassified
ContentEditable (Other open bugs)
unspecified
PC Windows 7
: Unprioritized major
: ---
Assigned To: Inez Korczyński
: i18n
Depends on:
Blocks: 56295
  Show dependency treegraph
 
Reported: 2013-07-02 09:59 UTC by vssun
Modified: 2013-10-29 07:39 UTC (History)
6 users (show)

See Also:
Web browser: Firefox
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description vssun 2013-07-02 09:59:29 UTC
I have noticed an unexpected behavior while tesing Visual Editor with Malayalam Wikipedia. Describing the steps below:-

1. Added the following text on a page

ഡിസ്രയേലി

2. When pressing a backspace immediately after the above text, it becomes

ഡസരയ

ie. many characters in between the original text disappeared. The expected result was ഡിസ്രയേ
Comment 1 Inez Korczyński 2013-07-06 18:09:18 UTC
@vssun: Any specific browser? Can't reproduce it in Chrome.
Comment 2 vssun 2013-07-06 18:17:39 UTC
Browser was Firefox 22.
Comment 3 vssun 2013-07-06 18:28:32 UTC
The bug 50507 is very much related to this. There, the reporter says that the characters ്, െ etc are not allowed to type.

Here the case is different but the characters are same. Characters, ി, ് and േ  (the vowel symbols of malayalam, which are joined together with preceeding consonants) are disappearing when pressing the backspace.
Comment 4 vssun 2013-07-08 07:10:47 UTC
(In reply to comment #1)
> @vssun: Any specific browser? Can't reproduce it in Chrome.

I could able to reproduce with Chrome (Version 27.0.1453.116 m)/windows 7
Comment 5 vssun 2013-07-17 06:55:44 UTC
Now the problem has been solved. You may mark this bug as resolved.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links