Last modified: 2014-05-20 20:56:59 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 50047 - VisualEditor: Dialog/flyout buttons cannot be activated with Tab key
VisualEditor: Dialog/flyout buttons cannot be activated with Tab key
Status: RESOLVED FIXED
Product: VisualEditor
Classification: Unclassified
MediaWiki integration (Other open bugs)
unspecified
All All
: High enhancement
: VE-deploy-2013-07-25
Assigned To: Ed Sanders
: accessibility
: 51913 (view as bug list)
Depends on:
Blocks: 367
  Show dependency treegraph
 
Reported: 2013-06-23 10:44 UTC by This, that and the other (TTO)
Modified: 2014-05-20 20:56 UTC (History)
11 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description This, that and the other (TTO) 2013-06-23 10:44:42 UTC
You can't tab from the edit summary box to the "Save page" button, or the reference inspector to the "Apply changes" button, etc.

This is important for accessibility. Currently, there is no way to confirm the action using only the keyboard.
Comment 1 Derk-Jan Hartman 2013-07-07 20:32:17 UTC
attr( { role: 'button', tabIndex: 0 } ) and add return keypress events to all of them.

Also dialogs should have role = dialog and buttons that pop up dialogs should have  aria-haspopup
Comment 2 This, that and the other (TTO) 2013-07-08 00:53:50 UTC
It's not really an enhancement, since it is preventing proper accessibility. But so long as it is looked at and fixed, that's what really matters :)
Comment 3 John Mark Vandenberg 2013-07-24 00:07:37 UTC
*** Bug 51913 has been marked as a duplicate of this bug. ***
Comment 4 John Mark Vandenberg 2013-07-24 01:53:14 UTC
*** Bug 51918 has been marked as a duplicate of this bug. ***
Comment 5 MZMcBride 2013-07-24 02:08:34 UTC
From bug 50897 comment 2:

In the old editor, I would simply use TAB to reach the edit summary, type my
edit summary and press ENTER to activate the "Save page" button and save. If I
wanted to mark the edit minor, then I could type my edit summary, press TAB,
SPACE, and then ENTER to "Save page".

I can see that the new box for entering an edit summary allows newlines to be
entered. I am not sure this is a good idea, because I just used a WSYIWYG
editor and now "What I see" - well-formatted paragraphs describing my edit - is
not going to be "what I get" - everything smashed on one line in the article
history. But that is perhaps grist for another bug mill.

It seems that the "Save page" button never receives caret focus if I use TAB to
try to get there. This would seem to have accessibility ramifications.
Comment 6 MZMcBride 2013-07-24 02:09:56 UTC
There seem to be two distinct requests:

* getting from the editing "surface area" to the edit summary input (with a tab key?)

* getting from the edit summary input to the save page or review changes buttons (with a tab key)
Comment 7 Gerrit Notification Bot 2013-07-24 13:48:19 UTC
Change 75594 had a related patch set uploaded by Esanders:
Makes ButtonWidgets more accessible

https://gerrit.wikimedia.org/r/75594
Comment 8 Ed Sanders 2013-07-24 13:51:19 UTC
Patch above should fix original bug. Issue of tabbing from surface to 'Save page' is also partly fixed, but because of DOM order you have to shift+tab. If we want to switch these round, please open a new bug.
Comment 9 Gerrit Notification Bot 2013-07-24 14:40:38 UTC
Change 75594 merged by jenkins-bot:
Make ButtonWidgets more accessible

https://gerrit.wikimedia.org/r/75594
Comment 10 James Forrester 2013-07-24 14:44:50 UTC
Fixed and will get deployed in a few minutes.
Comment 11 John Mark Vandenberg 2013-07-26 06:04:29 UTC
The current tab order is pants, and is not what was requested in comment 1 or comment 5.

From the edit summary box, the tab order is now:
1. the link "minor edit" beside the 'minor edit' checkbox.
2. "Save Page" button
3. "Review your changes" button
Then three tabs for the links in the footer of this windows.

Tabbing to the _link_ "minor edit" is a bug in the current implementation.

Unless there is a good reason to do otherwise, the tab order should be the same as the source editor (muscle memory).  See also bug 51918 for a tab order request.
Comment 12 John Mark Vandenberg 2013-07-26 06:04:39 UTC
*** Bug 52080 has been marked as a duplicate of this bug. ***
Comment 13 James Forrester 2013-07-26 23:20:34 UTC
This bug is fixed. Will use bug 51918 to track changes to tab order instead.
Comment 14 Luis Villa (personal-for work use lvilla@wikimedia.org) 2014-05-20 19:55:46 UTC
This appears to be broken again- can't tab to "save page" in the current release. Prefer to reopen this bug or file a new one?
Comment 15 James Forrester 2014-05-20 20:00:57 UTC
I can on enwiki, MediaWiki.org and Beta Labs – where are you having this issue?
Comment 16 Luis Villa (personal-for work use lvilla@wikimedia.org) 2014-05-20 20:08:50 UTC
Enwiki, Firefox nightly on Mac. But does seem to work on office with Chrome.
Comment 17 James Forrester 2014-05-20 20:56:59 UTC
Hmm, yeah, this has regressed for Firefox. Yay for browser bugs. Will follow-up on bug 51918.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links