Last modified: 2013-06-07 11:20:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 49268 - Edit Toolbar and Twinkle Gadgets are not loading properly at Bengali (bn) Wikipedia
Edit Toolbar and Twinkle Gadgets are not loading properly at Bengali (bn) Wik...
Status: RESOLVED INVALID
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
wmf-deployment
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: 40760
  Show dependency treegraph
 
Reported: 2013-06-06 19:16 UTC by Nasir Khan Saikat
Modified: 2013-06-07 11:20 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nasir Khan Saikat 2013-06-06 19:16:01 UTC
The "Edit Toolbar" and "Twinkle" Gadgets are not loading properly in Bengali Wikipedia. For more that one month we are facing this issue. 

The problem is these gadgets do not load all the time. When we open any page in edit mode sometimes these gadgets are missing. If we refresh the pages a number of times the one of the gadgets might load. but i for last one week i could use the Twinkle only a few times. 

We discussed this issue at our local village pump and many of the users agreed on this issue. But only one user said that he never faced this issue for the Edit toolbar, but for Twinkle the situation is same for him too. 
One of the user reported this issue on the Twinkle project page, but solution did not came[2]. 

[1] - http://bn.wikipedia.org/wiki/WP:%E0%A6%AA%E0%A7%8D%E0%A6%B0%E0%A6%B6%E0%A6%BE%E0%A6%B8%E0%A6%95%E0%A6%A6%E0%A7%87%E0%A6%B0_%E0%A6%86%E0%A6%B2%E0%A7%8B%E0%A6%9A%E0%A6%A8%E0%A6%BE%E0%A6%B8%E0%A6%AD%E0%A6%BE#.E0.A6.B8.E0.A6.AE.E0.A7.8D.E0.A6.AA.E0.A6.BE.E0.A6.A6.E0.A6.A8.E0.A6.BE_.E0.A6.9F.E0.A7.81.E0.A6.B2.E0.A6.AC.E0.A6.BE.E0.A6.B0_.28.E0.A6.9C.E0.A6.B0.E0.A7.81.E0.A6.B0.E0.A7.80_.E0.A6.AD.E0.A6.BF.E0.A6.A4.E0.A7.8D.E0.A6.A4.E0.A6.BF.E0.A6.A4.E0.A7.87_.E0.A6.AE.E0.A6.A8.E0.A7.8D.E0.A6.A4.E0.A6.AC.E0.A7.8D.E0.A6.AF_.E0.A6.AA.E0.A7.8D.E0.A6.B0.E0.A6.AF.E0.A6.BC.E0.A7.8B.E0.A6.9C.E0.A6.A8.29

[2] - https://github.com/azatoth/twinkle/issues/159
Comment 1 Andre Klapper 2013-06-07 11:20:15 UTC
Hi Nasir,
thanks for reporting this.

Looking at the Javascript console in Firefox when loading http://bn.wikipedia.org/w/index.php?title=%E0%A6%A2%E0%A6%BE%E0%A6%95%E0%A6%BE_%E0%A6%AC%E0%A6%BF%E0%A6%B6%E0%A7%8D%E0%A6%AC%E0%A6%AC%E0%A6%BF%E0%A6%A6%E0%A7%8D%E0%A6%AF%E0%A6%BE%E0%A6%B2%E0%A6%AF%E0%A6%BC&action=edit I get:

Error: TypeError: mw.usability is undefined
Source File: http://bn.wikipedia.org/w/index.php?title=Mediawiki:RefToolbarMessages-en.js&action=raw&ctype=text/javascript
Line: 8

Error: TypeError: EditTools.createEditTools is not a function
Source File: http://bn.wikipedia.org/w/index.php?title=Mediawiki:RefToolbarLegacy.js&action=raw&ctype=text/javascript
Line: 88

For the latter, if you check http://bn.wikipedia.org/w/index.php?title=%E0%A6%AE%E0%A6%BF%E0%A6%A1%E0%A6%BF%E0%A6%AF%E0%A6%BC%E0%A6%BE%E0%A6%89%E0%A6%87%E0%A6%95%E0%A6%BF%3AEdittools.js&diff=1222586&oldid=471948 you can see that the definition for the function createEditTools() was removed already in 2012, but RefToolbarLegacy.js was not updated accordingly.

So that's probably what you want to repair first, and then recheck the situation. http://www.mediawiki.org/wiki/MediaWiki_talk:Edittools and http://en.wikipedia.org/wiki/MediaWiki_talk:Edittools might also be a places for further support.

I'm closing this bug report as INVALID for the time being, as this problem is not about server configuration or MediaWiki code but about local scripts on a specific Wikipedia that anybody could fix on-wiki.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links