Last modified: 2013-05-13 11:40:00 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 47158 - Make rate limits work with Wikibase
Make rate limits work with Wikibase
Status: VERIFIED FIXED
Product: MediaWiki extensions
Classification: Unclassified
WikidataRepo (Other open bugs)
unspecified
All All
: Highest major (vote)
: ---
Assigned To: Wikidata bugs
:
Depends on:
Blocks: 18654
  Show dependency treegraph
 
Reported: 2013-04-12 08:25 UTC by Daniel Kinzler
Modified: 2013-05-13 11:40 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Daniel Kinzler 2013-04-12 08:25:25 UTC
The Wikibase API currently bypasses editing limits set via wgRateLimits. wgRateLimits is enforced by User::pingLimiter, which is called from EditPage. But we don't use EditPage.

So, the EditEntity class needs to call User::pingLimiter() to enforce rate limits.
Comment 1 Nemo 2013-04-12 08:33:37 UTC
This seems one of the many problems caused by bug 18654. Wikidata is probably also affected by bug 33461.
Comment 2 Daniel Kinzler 2013-04-12 09:12:01 UTC
@Nemo: yes, all the controller logic needs to be factored out of EditPage, so it can be re-used.

Our answer to this is to re-implement all the controller logic that is usually performed by EditPage in our EditEntity class - e.g. resolving edit conflicts, checking permissions, etc. So the rate check should go there, too.
Comment 3 Gerrit Notification Bot 2013-04-15 09:31:03 UTC
Related URL: https://gerrit.wikimedia.org/r/59119 (Gerrit Change I57fb295ca043c70bc754123e97495ead7e01d920)
Comment 4 Gerrit Notification Bot 2013-04-16 13:26:35 UTC
https://gerrit.wikimedia.org/r/59119 (Gerrit Change I57fb295ca043c70bc754123e97495ead7e01d920) | change APPROVED and MERGED [by Aude]
Comment 5 Gerrit Notification Bot 2013-04-16 13:34:38 UTC
Related URL: https://gerrit.wikimedia.org/r/59389 (Gerrit Change I57fb295ca043c70bc754123e97495ead7e01d920)
Comment 6 Gerrit Notification Bot 2013-04-16 13:40:21 UTC
https://gerrit.wikimedia.org/r/59389 (Gerrit Change I57fb295ca043c70bc754123e97495ead7e01d920) | change APPROVED and MERGED [by Daniel Kinzler]

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links